Having a problem running Jetty...PLEASE HELP

Hello developers, hope you are all well today. i have been having trouble with jetty since last year. I have tried with the help of others to a point of deleting my openmrs database and property runtime but still errors. Last i did below is the error i got. My password is perfectly fine. At first it gave me error about not accessing runtime property. I fixed the issue yet it still gave me errors of which i shared individually with one person from. I was advised to delete property runtime from the database but this particular error in the attachments below persist in the insrallment set up.

Hi @brenda29 consider looking at the solutions here

hope it helps

Thank you Tendomart. Could someone help me with a link to a mysql version 5.6.42 installer download. i have tried looking including on the mysql website but nothing so far. Please!

Have you tried this https://dev.mysql.com/downloads/mysql/

since this is an older version of mysql, it has been archived here → https://downloads.mysql.com/archives/community/.

  • you need to use the dropdown in the product version to select the version 5.6.42
  • Then use the dropdown in the operating system to select the operating system you need e.g linux, windows,etc…

i did but i only found the zip in the archives, no installer. The installer there is of the latest version.

Hey Herman thank you but i have found those zip files. I am looking for the 5.6.42 installer. Is it not there anymore?

Do you need 5.6.42 exacltly, any 5.6.x version should work, and if you’re doing this for openmrs, I encourage you to use higher versions .5.7

like MySQL Community Server 8.0.32 at the link which I Shared above.

Tendomart I am trying to replace the latest version with that version so as to see if the jetty will be compatible with it to avoid errors i have been getting on the openmrs set up log. I followed the link you gave me and someone had used the 5.6.42 and it worked.

@brenda29 that was to show you steps in solving the problem, openmrs 2.4 and higher supports mysql 8.0, openmrs 2.3 supports mysql 5.7, so using 5.6 may not work if the openmrs version you’re setting up is higher than 2.3


Thank you Tendomart. Let me try and follow this. Thank you so much for the timely replies.

I am actually using 2.0.0 version of open mrs. I may need to upgrade. Its what i stambled upon as a newbie and just went a head. Help me with a link to the current version. I might have to start everything a fresh.

Tendomart, i hope you are good today. Please help me with a link to the higher version of Openmrs. I had use 2.00 and now if i must install the higher version of mysql, i must change it. Thank you in advance.

@brenda29 sorry for the delay, do you want to download the platform

you can download from Download – OpenMRS.org

or OpenMRS - Browse /releases at SourceForge.net

or folk this GitHub - openmrs/openmrs-core: OpenMRS API and web application code and build locally on your machine.

Thank you Tendomart. Let me start a fresh…will let you know… thank you once again

1 Like