GSOC 2020 , OpenMRS Should Support PostgreSQL

@jwnasambu , Can you share the logs for your setup and also share the steps you followed to set up the Reference Application ?

I must admit my mistake. I didn’t save the logs I think I was enjoying everything running smoothly until when I downloaded and fixed the module snapshorts to C:\Users\JULIE\AppData\Roaming\OpenMRS\modules. But I have began setting a fresh and will share the outcome shortly. Am sorry!

No problem, just make sure you use the snapshot version of all the Ref. App. modules.

@dkayiwa @jwnasambu , I have moved the documentation under the Installing OpenMRS section in Implementor Documentation.
https://wiki.openmrs.org/display/docs/OpenMRS+Setup+On+PostgreSQL

Thanks for the patience .

I began by running the mvn -Djetty.port=8888 jetty:run to access my already set OpenMRS Platform on PostgreSQL as you can see below

I then downloaded the snapshot modules by setting up an SDK instance 2.11.0 which I believe corresponds to the platform version 2.4.0 and copied all the OMOD and owa files in my modules folder on this path C:\Users\JULIE\AppData\Roaming\OpenMRS\modules then restart the web server and this is the outputlogin

When I click Log in I get this screen

and these are my logs https://pastebin.com/QtFF4ajB I wouldn’t like to share functionality outcome because the error may be originating from my side.

@jwnasambu , Can you try using this link : https://ci.openmrs.org/build/result/artifactUrlRedirect.action?planKey=REFAPP-OMODDISTRO&buildNumber=10213&artifactName=referenceapplication-addons-snapshot to get the snapshot of RA modules and do a fresh installation of OpenMRS-core ? Also choose the option of creating a new database when initializing.

I just now initialized the ref. app. and its working fine. From the logs it appears that some liquibase changesets are failing which may be because of the db holding the failed checksums result of previous failed initialization.

Sure! Thanks so much for your tireless efforts.

1 Like

@aman I finally managed to install the reference Application modules on PostgreSQL as reflected on this snap short

I was able to test how the reference Application functionality behave on PostgreSQL and my findings are on this link
For testing purposes I used this link https://qa-refapp.openmrs.org/openmrs/index.htm hand in hand with my PostgreSQL server.

Thanks.

1 Like

yes @dkayiwa

I have tested out the functionalities in this guide and in this one and they work except that when you click on Manage Modules , Manage Apps & System Information apps i get

HTTP Status 404 – Not Found

Type Status Report

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Apache Tomcat/8.5.42

Does that work when you are running MySQL?

Am glad we have the same output.

Since we have the same output, on my mysql it works well but the HTTP Status 404 – Not Found is displayed on postgresql server on this three modules Manage Modules , Manage Apps & System Information apps

yes @dkayiwa

as @jwnasambu has responded it works when running MySql

@gcliff @jwnasambu , for these sections you need to setup - System Administration OWA. Have a look here : https://wiki.openmrs.org/display/docs/System+Administration+OWA . I have tweaked this as well and it should be working fine. It’s working fine on my local system.

1 Like

@aman i uploaded the system admin owa and its working well according to the wiki page however the apps are still not responding… It works fine in the legacy ui and failing in the reff app

@aman Could it be because of this

and so we need to create a new database to initialize the changes because refreshing the core is not picking the changes?

No this should not be the issue since no repeated changesets will be getting executed due to the addition of the OWA.

Thanks for the clarification.

@gcliff @jwnasambu , I looked into the issue and found that if you go into owa folder in the openmrs config folder, you will find the folder SystemAdministration -1.2 . If this is the case, then rename that folder to SystemAdministration and re run the application. The issue should be resolved.

Apparently, if you use the link : https://ci.openmrs.org/build/result/artifactUrlRedirect.action?planKey=REFAPP-OMODDISTRO&buildNumber=10213&artifactName=referenceapplication-addons-snapshot to download the refapp modules then the downloaded owa file has the name SystemAdministration.owa , so the created folder in owa directory is also SystemAdministration hence everything worked fine for me. I directly copied the the modules and owa folder and everything worked fine

1 Like

CI PLAN FOR POSTGRESQL

Hi everyone I had been working for framing out a Bamboo CI plan to run the liquibase changesets against PostgreSQL db on every commit on Bamboo server. I am unsure of what should be the exact behavior, so here I have some questions :

There are 3 files namely liquibase-schema, liquibase-coredata and liquibase-update-to-latest xml files having the necessarry changesets.On every commit

  • Should we clear the db and re run all the changesets and on success again clear the db?

  • Should we run only the newly added changesets and db must always store the content of previous executed changesets ? When there is an error during execution, then db might be left in inconsistent state ? Liquibase rolls back failed changesets but not already executed change sets.

I am new to CI so pardon if I am stating something wrong. :slightly_smiling_face:

cc @dkayiwa @ibacher and anyone with suggestions