GSOC 2017 - Data Integrity Module 4.x Improvement Project

Hi ,

I am preparing for create a proposal for this project and i get a small issue.I config the open MRS core project in my local machine and it worked fine with master branch. But data integrity module is not working in the open mrs.

This error message popup in the every UI.

Thanks, Ridmal.

Can you share your server log at

This is the error that i am facing .

Actually i fixed that problem by removing dataintergrity_result table in my mysql database.But now i am facing another problem which is not show the data integrity workflow methods in openmrs administration panel.

Server error is

Check the module’s source to confirm if that class actually exists.

@ridmal That error arises when the module is not started, can you look further up in the logs to see what error caused the module not to start

This is the complete log when i run the open mrs with jetty server.

@ridmal Can you go to Adminstration -> Manage Modules

You will see the Data Integrity Module probably has a green button next to it, click the button and see what happens

Data integrity module starts with this log .

( Actually i used master branch of openMRS-core to run open mrs. Is it can be the problem ??)

@ridmal I have only been running it on 1.11.x platforms, this is issue may be with 2.x core - can you change to that branch and try again?

Ok i tried to configure openMRS - core 1.11.x . But it gives me this error when i run with the jetty server. ( NOTE - i tied with several ports to run jetty server )

You may have background servers still using the ports from previous runs . However have you tried OpenMRS SDK - I think it will simplify your setup and development workflow

Ok i will try that . .Thank you for your help @ssmusoke

Ok i will check that .

@ssmusoke downloaded the openmrs-sdk and create a server with both distribution ( 2.0…) and platform(1.11.7) options.Both will properly run and i added the data integrity modules too.But still it doesn’t show the data integrity options in administration panel.

@ridmal the data integrity module does not provide legacy app links these have to be within the Reference Application. So create a reference application 2.4 distribution you will see it on the home page

Ok . working on that .

FWIW, i have just loaded the dataintegrity module in platform 2.x and it loads without any errors.

Using openmrs-sdk ??

can you send me the screen shots of administration panel you got after loading the openmrs server.