GitHub on Docker Bahmani project

Hello @MekomSolutions

I try to install and test your Docker Bhamani Project. I believe it is a good project because it has all the necessary things such as a lab, a Data chart, and so on.

I tried much time to install from GitHub clone the repo and use docker-compose up commend, but I can not successfully log to bahmni.

In your instruction, I can not find Bahmani’s username and password. Would you provide me default username and password? Also, I had some problems when logging Openmrs, it has not accepted username and password. I try to use your default username and password: superman and Admin123, but it does not accept it. Also, Would you tell me what is requirement ram and memory needs are for install of this project?

Please give me the solution and step-by-step instructions. Thank you!

1 Like

Hi @shahin1 ,

The username/password is documented in the README actually. See Access The Servers section.

That said, those are are superman/Admin123 such as what you’ve tried.

So if this did not work, it may be that the Bahmni Core module did not start correctly (as it’s the one creating the superman user).

Could you try accessing http://localhost/openmrs and log in with the default OpenMRS creds, admin/Admin123, and see if that works?

If you run the full suite (EMR, ERP and LIS) then you would be confortable with 8GB (6GB probably ok too).

If EMR only, then 4GB would do.

In terms of storage, it really will depend on your usage of the application but I’d say 16GB of storage is a good start.

Hello @mksrom, Thanks for the reply! I still have the same problem when I run on digital ocean and Azure cloud service. I am sending screenshots would you take a look?

Also, Would you tell me if your project can run Arm A1 Instances in the oracle cloud?

I am thinking I am doing wrong to install the Docker Bahmani project. Would you give me first to last step-by-step instructions which would be so helpful for me?

I follow like this: step one: Install on docker & docker-compose in ubuntu server 18 step two: clone the repo type git clone GitHub - mekomsolutions/bahmni-docker-compose: Docker Compose project to run Bahmni step three: cd bahmni-docker-compose step four: docker-compose up That’s all is it right this instruction? Thank you

1 Like

OK. Looks like something is wrong with starting OpenMRS altogether. The steps you’ve followed may not be the most recent ones.

Could you follow the Quick Start as explained in the README?

  • Download Bahmni Docker Compose itself.
  • Download the Bahmni distribution of your choice. You can use our Haiti distribution as a base start (as suggested in the README).
  • Start Bahmni.

I’ve just tested it and made a slight update to the README. Let me know how that goes.

As for this, we do publish Docker images that are compatible with Arm architectures, so this should just work fine, without doing anything special.

Aright, from what I see, the $VERSION variable has no value assigned to it.

Did you do the first step and did it run successfully?

Make sure to keep using the same terminal session/window as the variables that you export are only available for that session.

  • @mksrom Would you tell me what would be $VERSION variable value?
  • Yes, I did the first step and did not succeed but, the second step “Bahmni Distro Haiti” was successful. I can not find the requirement instrucation of your project. what port does need to open? Does it need java and what version? Does it need maven? Also, Does it need a docker? Thanks
export VERSION=1.1.0-SNAPSHOT
mvn org.apache.maven.plugins:maven-dependency-plugin:3.2.0:get -DremoteRepositories=https://nexus.mekomsolutions.net/repository/maven-public -Dartifact=net.mekomsolutions:bahmni-docker-compose:$VERSION:zip -Dtransitive=false --legacy-local-repository
mvn org.apache.maven.plugins:maven-dependency-plugin:3.2.0:copy -Dartifact=net.mekomsolutions:bahmni-docker-compose:$VERSION:zip -DoutputDirectory=.
unzip bahmni-docker-compose-$VERSION.zip -d bahmni-docker-compose-$VERSION

will do.

Thanks for pointing this out. I’ll add this in the documentation. For info, it requires:

  • Maven
  • Docker
  • Docker Compose

in recent versions.

As for the ports, it would be 80 (443 if SSL is enabled) (Proxy: OpenMRS, OpenELIS), 8069 (Odoo) and 9003 (Metabase) by default. You can of course override any of those.

Hello @mksrom I try of your advice, unfortunately, I can not successfully install the docker Bahmani project. Please take a look at the screenshot and let me know what is wrong.

My suggestion would you try this project run into your virtual box and let me know does it get any problem or not? Thank you

I’ve made some more changes in the documentation in order to improve clarity and simplify the commands to be run. You just have to copy and paste it at this point and things should work. I’ve tried it many times now.

However, if you’ve had run everything correctly but there is still an error, would you mind sharing the log of the OpenMRS container? In https://paste-bin.xyz/ or equivalent.

Running docker logs haiti_openmrs_1 > openmrs.log should save the logs in a file.

Mind that the container name may not be haiti_openmrs_1 but haiti-openmrs-1. Check this with docker ps.

Additionally, you may want to down -v everything in order to be sure to start afresh.

This link does not contain the log.

About the issue, I would suspect that the your openmrs service volume does not point to a place where the modules are. So probably an issue with your exports.

Could you share the results of this (when run in the same window where you’ve exported the variables):

echo $OPENMRS_MODULES_PATH
ls -al $OPENMRS_MODULES_PATH