Getting quiz result for Smart Developer badge

So I can see that @isamanya finished the test 10/12/2020 2:54:29 (UTC).

I can see in the application logs tried to grant Smart Developer .

[2020-10-13 05:02:30.767] [INFO] grader.js - isamanya granted Smart Developer 

Now I have no exception whatoever in the logs. Well, that will be fun.

1 Like

@burke I tried restarting the app and rerunning it (removing the data from the spreadsheet), and it doesn’t seem to be working anymore. The code looks pretty straightforward, but somehow it’s saying it’s a success and it’s not doing anything.

Seems to be happening since I upgraded talk.

1 Like

Working through this. Quizgrader is a bit rusty. I managed to get a dev instance to run. Quizgrader is getting a “BAD CSRF” error when invoking the Discourse API. It looks like the problem is coming from this change in Discourse, where API authentication is now done via the header.

I think I’ve got it fixed (and cleaned a little rust off quizgrader along the way). I’ve committed my changes, but don’t know if those will make it into the infrastructure automatically. I’ll try to check on that tomorrow.

3 Likes

So I checked dockerhub, and the build was red (it was configured wrong, pointing to wrong folder). I fixed it.

Then I ran on the machine hosting it to update the image:

deploy-compose quizgrader

I went to the spreadsheet and deleted the grade for @isamanya, and rerun the quizgrader. That seems to have done the trick!!! YEY

2 Likes

@cintiadr, Thanks so much for upgrading Discourse! Since I was touching quizgrader, I added in log entries for any errors coming from Discourse. Hopefully, we won’t need them… but, if we do, the log entries will be more helpful next time. :slight_smile:

1 Like

Thanks @jwnasambu, @cintiadr and @burke. I got the feedback .

2 Likes

@cintiadr, @burke and @dkayiwa kind help please! @pasindur2 has done the quiz twice and he has not got any feedback within the 24hrs hours of submission. I kindly request you look into his issue at your convenient time please!

1 Like

I’ve been looking into this. There were a few issues.

  • Some of the earlier problems were because the PR entered did not match the pattern required (i.e., the PR wasn’t to a repository within the OpenMRS org).
  • More recently, some of the identifying info (most importantly OpenMRS ID) wasn’t getting copied over by Zapier. I refreshed the Zapier “zap” and it seems to have fixed that problem.
  • The quizgrader is unable to reach OpenMRS Talk because it considers Talk’s TLS certificate to be invalid. I think it might be related to this issue and asked @cintiadr her thoughts on how to fix it. It’s possible rebooting that machine might fix the problem.

BTW… our dev1 quiz is woefully outdated and needs attention. I’ve started a Google Form version but haven’t had the time to refactor a new version of quizgrader to make it work. That would both get rid of some of the outdated questions and eliminate the need for SurveyMonkey + Zapier for the dev quiz.

4 Likes

I’ve upgraded the version of node used by our quizgrader and that seems to have fixed the certificate issue being caused from older versions. @pasindur2 received the Smart Developer badge as expected and should be granted the /dev/1 badge within ~24 hours.

2 Likes

Thanks, @burke @jwnasambu for your kind help. It means a lot.

@jwnasambu I finally also attempted the quiz a few days ago however I haven’t had any responses yet Any kind of help is appreciated Thanks !!!

@dbaluku you should’ve gotten the badge after your first attempt; however, something is preventing contact information from being properly populated. So, the quiz grader can see all of your answers and successfully grade the quiz, but it doesn’t have your name, email address, or OpenMRS ID populated for some reason.

I’ll need to do some more troubleshooting. There’s no need for you to take the test again. Once I get it working, you should receive your badge.

@burke Have also tried now for a while so far like two-three times but no response…

@jonathan am sorry to reply you on a public thread when you reached out in private but its my desire to encourage someone else facing the same challenge that @burke is fixing the problem

Am sorry you had to do the quiz thrice we are deeply sorry for the inconvenience. Just keep pushing code you never know you may be the second after @ibacher from dev null to Dev4. :slightly_smiling_face:

1 Like

Thanks @jwnasambu

wow @ibacher :handshake: @jonathan u did it…indeed #push code

I finally got around to fixing the /dev/1 quiz…

                                                   
The quiz has been held together with bailing wire & duct tape, with Zapier migrating Survey Monkey form entires a Google Spreadsheet and notifying an old, manually deployed node-based quiz grader service. I updated the quiz grader node app libraries & refactored its code, added a GitHub action to automatically deploy any changes, and replaced the old Survey Monkey quiz with a new Google Form that automatically triggers the quiz grader each time a form is submitted. :slight_smile:

I migrated recent responses that hadn’t been graded to the new version of the /dev/1 quiz, which means a Smart Developer badge has now been granted to @jonathan, @kumuditha, @dbaluku, @pwargulak, @richa09, and @abertnamanya. (Reminder, it can take up to 24 hours from getting the Smart Developer badge to being granted the /dev/1 badge)

5 Likes

Thanks @burke :smiley:

Thank you @burke!

Thanks @burke

Great, thanks @burke !