Getting Errors while building the openmrs-distro-referenceapplication app on Docker

Hello here I am trying to deploy the openmrs-distro-referenceapplication on my machine on docker. But whenever I try to build the project using docker compose build I get these two errors.

=> ERROR [openmrs/openmrs-reference-application-3-backend:qa] resolve image config for 37.6s

=> ERROR [openmrs/openmrs-reference-application-3-gateway:qa] resolve image config for 28.3s

Not sure where the problem is coming from. @nsanzimanagilbert @ibacher @dkayiwa

Can you share the full build log via

Here is the full log

Is this of any help? docker - An error, "failed to solve with frontend dockerfile.v0" - Stack Overflow

1 Like

The build was successful thank you. @dkayiwa

It greatly helps others sharing what you exactly did to fix this.

1 Like

Oh yes sure

  1. I went to docker desktop
  2. I opened the settings
  3. Went the option of Docker Engine.
  4. then I changed the docker buildkit variable from true to false.

After this I didnt have any errors when building in docker. After build though I got another error Error while running the docker compose up -

I tried stopping the images already running on this port but still I get this error Error Log when I clear the images used by port 80 -

1 Like

Do you still get the exact same error even after restarting your computer?

Yes I get the same error even when i restart.

Can you scan for the process which is using that port on your operating system?

I faced a similar issue before. If you have Nginx installed on your PC disable it.

I used sudo lsof -i :80 to check which services are in use and stopped them all. I run docker compose up again but it has taken like 2 hours to and it is still running.

Let me try this. Though the intial error was that I didnt have Ngnix, and I installed it but let me try disabling it.

Actually I didnt have Nginx installed.