Getting an Error when running openmrs-sdk:run

You have the following servers::

  1. server

Which one do you choose? [1]: 1

Checking if port 8080 is in use… [free] [INFO] OpenMRS module detected, installing before run… [INFO] Configured Artifact: org.openmrs.module:basicexample-omod:1.0.0-SNAPSHOT:jar [INFO] Copying basicexample-1.0.0-SNAPSHOT.omod to /home/krishnanspace/openmrs/server/modules/basicexample-1.0.0-SNAPSHOT.omod [info] Module ‘basicexample’ was updated to version ‘1.0.0-SNAPSHOT’ [INFO] ------------------------------------------------------------------------ [INFO] Reactor Summary: [INFO] [INFO] Basicexample … FAILURE [ 4.101 s] [INFO] Basicexample API … SUCCESS [ 13.165 s] [INFO] Basicexample OMOD … SUCCESS [ 8.595 s] [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 31.780 s [INFO] Finished at: 2017-12-12T10:50:48+05:30 [INFO] Final Memory: 53M/366M [INFO] ------------------------------------------------------------------------ [ERROR] Failed to execute goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.12.1:run (default-cli) on project basicexample: Execution default-cli of goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.12.1:run failed.: NullPointerException -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1]

Whenever I am executing this command I get the above error.Dont know what caused it.Also what is the command to shutdown the tomcat server?Like openmrs-sdk-run will start the tomcat server,but in the documentation,there is no mention of shutting the server.

Hello @krishnanspace, sorry about the error, What operating system are you using?

On windows, Go to the appropriate directory of the Tomcat installation. 

Under the bin folder you will see startup.bat file , if you right click on it and run as admin, it will start Tomcat.

Then in the same bin folder you will see shutdown.bat file, double click it and it will shut down Tomcat.

To startup the Tomcat server from the  command line; 

Change the directory to the bin directory of Tomcat and run this command. On Linux: ./

On Windows: % startup.bat

Likewise to shutdown the Tomcat server in the command line use the following commands

On Linux: ./

On Windows: % shutdown.bat

I hope it will help you.

1 Like

But I am using the Tomcat which is bundled with OpenMrs Sdk,so there is no Tomcat Directory on my Ubuntu.Thanks for the reply!


Any progress on this?

Since today morning we are having the same issue. We tried mvn versions 3.3.9, 3.5.0, 3.5.2 and openmrs-sdk 3.12.1. Here is full log:

We would like to know how to proceed with this.

cc @pkornowski, @pgesek, @kcissewski

Regards, jtrzebiatowski

I have been getting this for the past two days. I thought I some how corrupted my installation so I deleted the maven repository for the sdk and reinstalled it using the command from the website but I still get this error.

I have

  • Apache Maven 3.5.0
  • macOS High Sierra
  • Java version: 1.8.0_144, vendor: Oracle Corporation

cc @SolDevelo

Just wanted to cc @raff :slight_smile:

I thought he was part of the SolDevelo handle. Did I just tag 15 wrong people?

There could be a problem because I am also getting a similar error.

@raff Looks like its related to this commit

Yeah I’m not able to create a new project using the mvn openmrs-sdk:create-project command. I’m getting the same error.

I’m on it.

Update: Releasing a fix right now… It should be available in an hour. Please use mvn openmrs-sdk:setup-sdk -U to force upgrade.


Thanks @raff now back to working …

Thanks so much @raff now some one can breath again! :slight_smile:

hey @raff,
I am getting the error saying -
please tell me the solution

Oh sorry for the error! you are supposed to force the upgrade by running mvn openmrs-sdk:setup-sdk -U command as reflected in this guide

1 Like

[ERROR] Failed to execute goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.6:run (default-cli) on project openmrs-webapp: Execution default-cli of goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.6:run failed: There is no server with server id: true. Please create it first using openmrs-sdk:setup.

In your command, mvn openmrs-sdk:run -DserverId = server1 can you remove the spaces and ensure that the name is exactly as expected? Alternatively, do not specify a server such that you get a list to choose from.

1 Like

Thank you very much!! Now Everything works fine.:blush: