failure to build the sdk

hello all, i modified some code in the platform module archetype on after modifying the code i run mvn clean install and got a build failure as seen here, what could be the cause of this error? @mozzy @ruhanga @tendomart @samuel34

@gcliff , you may want to restart your computer then re-run mvn clean install if you haven’t tried this already.

sorry @gcliff i have just seen this now. how far ??

Hey @mozzy am still getting this

frm this

1. Cannot run program "node": CreateProcess error=2, The system cannot find the file specified

    2. Cannot run program "npm.cmd": CreateProcess error=2, The system cannot find the file specified

it seems to me you dont have node and npm installed

what does these commands return on your command line

npm -v
node -v

@mozzy i did re-clone the sdk built again and it worked on integration test where i was getting failures tho, working on how to use the locally edited sdk

@gcliff , i havent undesrtood exactly the above statement

@mozzy after making changes in the code and building successfully and how to install the edited sdk

@gcliff , can you take a lose look at the sdk read me page on the sdk repository… there is a section .development . i would think it expalins how to do so

some thing like this

To run a SNAPSHOT version of SDK, you need to specify groupId:artifactId:version for all SDK commands, e.g.

`mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:2.1.3-SNAPSHOT:setup-platform`

copied that from the sdk read me

@mozzy i have seen and run but got this

@gcliff, this is waht i get when i click that link

This page is no longer available. It has either expired, been removed by its creator, or removed by one of the Pastebin staff.

@gcliff you also dint reply me here

sorry for not replying on that early and @mozzy it says its not recognised as an internal or external command

so you should install npm and node on your machine first

@mozzy thanks man :+1: and how will i use them

well node provides a run time enviroment for certain front-end frameworks. but ofcourse its one of the causes of the errors for your build failure when i go through the logs here

youll stiil use it to bulid some core modules like the “core-apps module”, some OWAs etc

so just make sure you install node. then try to first succesfully buil the sdk on your local machine before you make any local changes