Failing to commit changes to GitHub using git push --set-upstream origin TRUNK-5208

This is the 3rd day when I try to commit some changes to github without any success. Now while trying to push new changes, via the terminal, I get the following error even after forking the repository a fresh:

Deniss-Air:openmrs-core juliet$ git push --set-upstream origin TRUNK-5208
 ! [rejected]            TRUNK-5208 -> TRUNK-5208 (non-fast-forward)
error: failed to push some refs to ''
hint: Updates were rejected because the tip of your current branch is behind
hint: its remote counterpart. Integrate the remote changes (e.g.
hint: 'git pull ...') before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details

When I run git status it shows nothing to commit, working tree clean followed by git log which gives this output. When I check my remote git the commit doesn’t exist. Kindly how can I go about it?

Thanks in advance!

@ibacher, @dkayiwa

Please try running git pull --ff-only --rebase --autostash then run git push.

gives this output

Deniss-Air:openmrs-core juliet$ git pull --ff-only --rebase --autostash
There is no tracking information for the current branch.
Please specify which branch you want to rebase against.
See git-pull(1) for details.

    git pull <remote> <branch>

If you wish to set tracking information for this branch you can do so with:

    git branch --set-upstream-to=<remote>/<branch> TRUNK-5208

Deniss-Air:openmrs-core juliet$

@ibacher still getting the same error.

@jwnasambu Please run git branch --set-upstream-to=origin/TRUNK-5208 then run the git pull --rebase.

@ibacher Am sorry for a bother. When I do git log I get this output commit 4096b3865e8d2c63fd94f55baf231bfa0eec55b1 (HEAD -> TRUNK-5208)Author: jw - but I can’t access the commit on my repository. Kindly how can I go about it?