Failing on pull Docker-compose for referenceapplication-distro

Hello , I have been trying to install docker and run docker on my machine windows10 64bit , Installing docker run smoothly but when it came to install openmrs on docker specifically docker-compose for reference-application distro, all in vain, however am not sure whether i have been following the right wiki which is this install on openmrs-on -docker. The main use case for this is to run for testing purposes since am working on related ticket. . This [link](http://docker-compose version 1.23.2, build 1110ad01) also provided initial points.

  1. With in the docker-compose.yml, directory its where i run # docker-compose up -d openmrs-referenceapplication . Kindly guide me, am running docker-compose version 1.23.2
  • 2.In docker-compose.yml file i shared, am sure its where all the necessities needed for running it which is in the directory am running on. what am not sure is whether they are other more dependencies i needed to add into the directory am running that goes with docker-compose.yml

cc @dkayiwa @ibacher @mogoodrich

As I understand from the discussion on the ticket…it appears u can reproduce the bug by just using the SDK (has this failed too)?

Thanks @reagan, Haven’t tried using sdk since i have been all the day encounting different error per error. However the error about the ticket can also be reproduced on any standalone compared to demo.Wanted to run it on docker for more testing coverage

@sharif did you succesfully Install Docker on your Windows’s Machine ? Plus how much RAM do you have ?

Sure i have successfully installed docker and its up and running. though got challenges with running openmrs-ref-distro. According to ram, i got rid of it by running docker-compose since it comes well packaged with its dependencies, No need of customising things manually which may eat up RAM.

Have you tried following the instructions in the readme file?

$ docker-compose up

Or the instructions in the wiki

docker-compose up -d

There are no other dependencies needed. All you need (database, data inside the database, openmrs and all plugins) are already part of the docker images and configuration.

That’s exactly how demo is setup.

1 Like

Thanks @cintiadr for clarification, Have been following in the readme.file however am still working on it.

Hello @cintiadr , have been trying out the steps but am getting blocked ,

  1. When i try to run # docker-compose up without changing anything from the getting this error Error.i seem to also be Concerning of identations and curry braces which may also behave unexpectedly which i considered also

2.When i tried to define docker environments without defining them using variables like here landed into error .What am not sure of is whether i need to update the version of docker-compose.yml because i had seen similar issue but was successfull using docker-compose version 3.0+. Kindly advise thanks

Reading google, the error ’ no matching manifest for unknown in the manifest list entries’ means your docker is trying to find WINDOWS docker images to run, and of course there isn’t any.

How I don’t know how you can configure your docker in windows to run linux images, but before you can run:

$ docker pull ubuntu
$ docker run ubuntu echo hello

You won’t be able to run any of OpenMRS images. They are all linux based, from the time that Windows didn’t have native docker

Thanks @cintiadr i will try configure using linux on windows and see whether there is any progress

1 Like