Failed to upgrade to Bahmni 0.93 from 0.92

My previous installation was working fine:

CentOS 7.6 - Bahmni 0.92-155

I followed the instruction Steps to Upgrade Bahmni to 0.93.2 Version to upgrade

I got first errors stating the sudo was deprecated . I then edited all files and replace sudo with become. Those are the files that I edited:









Then the installation failed again with the error:

ERROR! ‘always’ keyword cannot be used without ‘block’

The error appears to be in ‘/opt/bahmni-installer/bahmni-playbooks/roles/bahmni-backup-upload-directories/tasks/main.yml’: line 14, column 3, but may be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  • always: ^ here

Hello @gabykant. The issue looks strange. Can you try installing Bahmni 0.93 fresh and copy over the database backup, files from 0.92 to 0.93

Yes I did already but I faced another issue as explained here:

Now I was considering upgrading the old server to the same version before backup/restore again to the new server.

What would happenned if I did this on the old server







Then I run the Bahmni Backup-all to backup all databases and files to the new server. Then I can run Bahmni restore from the new server on a fresh Bahmni installation

@binduak @angshuonline Could you help here ?

@gabykant what is the ansible version that you have installed ?

Here is the output given by the version command

ansible 2.9.27
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Nov 16 2020, 22:23:17) [GCC 4.8.5 20150623 (Red Hat 4.8.5-44)]

Bahmni 0.93 uses ansible 2.4.6 … maybe thats the issue? How was ansible installed? Bahmni install scripts should download ansible from this location, by default.

On the Old server I had a problem installing bahmni -i local install I used this and it worked bahmni -i local -aru install

Still no reply. No success. I have uninstalled then reinstalled and restored back again and again but same error

We had a connect today to understand the issue. The issue happens specifically on Odoo.

Steps followed by @gabykant

  1. Fresh Install of Bahmni 0.93
  2. Took database backup from 0.92 Bahmni server
  3. After database restore on fresh Bahmni 0.93 installation, Odoo starts showing up the errors as attached.

Seems like some issue with schema of Odoo. @angshuonline @binduak @gsluthra Any thoughts?

Hi @mohant

Any update about the issue ?