Facing Problem while setting up Openmrs server locally

I am trying to run mvn jetty:run on my ubuntu os . It is showing that server 8080 is alredy in use .

I tried to check if any process is running on that port with this command **lsof -i :8080 ** but it is showing that no process is using this port . I tried to start with some different port like 8081 and it started but the website is not working it is showing The Site Cant be Reachead Can anyone please guide me

@secretkontributer what is the output of this command mvn -v?

@suubi7 Apache Maven 3.6.3 Maven home: /usr/share/maven Java version: 11.0.21, vendor: Ubuntu, runtime: /usr/lib/jvm/java-11-openjdk-amd64 Default locale: en, platform encoding: UTF-8 OS name: “linux”, version: “”, arch: “amd64”, family: “unix”

@secretkontributer Had you run this mvn clean package was the build successful (if not kindly share log). Also I think you may need to down grade to java 8 rather than java 11 Once you switch the java version restart your computer and run mvn clean package then deploy the app again using mvn jetty:run in the webapp directory.

cc: @dkayiwa

@suubi7 i downgraded my java version to this 1.8.0_392 . I tried what you said and my mvn clean package was successfull also .Still i am getting the same error

@secretkontributer And your JAVA_HOME environment points to the Java 8 JDK?

unable to run the yarn command what should I do?

@secretkontributer you are not in the right directory You need to run this command in the openmrs-esm-core directory.