Facing error related to drug and diagnosis in OpenMRS-DrugOrders-Pharmacymodule

Tags: #<Tag:0x00007f5ff73c47a0> #<Tag:0x00007f5ff73c46d8> #<Tag:0x00007f5ff73c4610>

Hello there since last week trying to build order entry module. unfortunately failed to build it because I wanted to add print functionality in it but its not generating .zip file thats why cant able see my changes. Tried all steps but fail.

After spending time and getting help from community came to OpenMRS-DrugOrders-Pharmacymodule suggested by @sharif . I installed the module and its working fine and matches the expectation specially in Indian style of pharmacy.

Unfortunately while adding drug order I am encountering the error message related to concept (Diagnosis concept class) like in below image.

Please help me on this It will really Helpful for me. @sharif @ibacher @dkayiwa

Thank You

Ohh sorry for late response, you need to create a diagnosis concept in concept dictionary NOTE, GoTo AdministrationPage, Manage Drug Concepts, Create a new Concept as Diagnosis Type

Thanks @sharif I wil try it and let you know.

hi @sharif after following steps got this fields.

are sure or I think we need to add it into Manage concept class.

from this point add a concept that you will later on use when making an order

1 Like

sorry my bad, From administration Page, click on dictionary, Click On add New Concept , and create a diagnosis concept

1 Like

This also might give you broad overview of handling concepts in openmrs Concept Dictionary Basics - Documentation - OpenMRS Wiki

1 Like

After setting up this got this error. UI Framework ErrorRoot Errorjava.lang.NullPointerException at org.openmrs. - Pastebin.com.

Hello @sharif and @herbert24 , I have created a new concept of Diagnosis type named “demoDisease” and created new order using that concept like below:-

but got this error after creating new order using newly created concept of diagnosis type:-

Create a concept from administration > Dictionary> addNew concept please

I have created new concept through reference application i.e. Home > Configure Metadata > Manage Concept dictionary > Manage Concepts > Add new Concept

I think both the ways will create a new concept.

Added new concept with concept class diagnosis and also added a concept with concept class drug. And in drug order chooses the same concept for drug and diagnosis but unfortunately got the same error.

The concept should reflect unless you are adding it differently

can i take you through concept creating To join the meeting on Google Meet, click this link: meet.google.com/rhy-hnjn-ugj

1 Like

Ok @sharif I think It will be better for us :sweat_smile:

Hello @sharif got disconnected. Can you please join it again.

Thanks @sherif I will try it again with fresh mind and let you know.

1 Like

@sharif I think we need to compare our provider things of person i.e admin

here in manage account page its showing identifier to unknown and in the code we are looking for clinician and doctor as a provider in drug

Hello @atiq , Are you still facing a challenge with saving a concept , can you share the error logs, probably that might be in code or some incompatibilities with core version

Hey @sharif able save the concepts successfully , but fail to place drug order unlike on your system.