Expect delays for infra tickets - can someone help? :D

They are not able to register because of the timeout issue. After they attempt for several tries, we tey to create in formage.

1 Like

I have not been part of the infra team, but i think now i should join, because some of these issues affect my other responsibilities. :slight_smile:

I could start with the not so complicated tasks like manually creating OpenMRS ID for those that fail, and a few others. Do you mind pointing me to some resources to guide me in how to help with these?

2 Likes

See PM – there is no need for a guide.

Not that I’ve been helping much, but I’m pretty much out for the summer (June through September) as I’m doing an internship. I’m using my OpenMRS time for GSoC mentoring. I strongly support letting @dkayiwa help out :slight_smile:

Sure! Here’s the guide for granting access for users in wiki and jira: https://github.com/openmrs/openmrs-contrib-itsmresources/wiki/Grant-Access-new-users

How to create a user if ID is timing out: https://github.com/openmrs/openmrs-contrib-itsmresources/wiki/Create-new-user

I think @burke can sort out permissions for you in helpdesk to see infra queues. Do you want to schedule a call this weekend so I can go over those guides if you have any questions? :slight_smile:

@cintiadr that would be awesome! Like the call you set up for me the other weekend was very very helpful! :smile:

2 Likes

Thanks again @cintiadr for walking me through this on the call. You are as awesome as always! :smile:

@burke we noticed that, though i already have access to helpdesk, i do not yet have access to the Infra tickets that include openmrs id issues. Could you, or @pascal, or any one else grant me access?

@dkayiwa – there is fine-grained access set up. Currently – only the infra team has access to those queues. I set up a bunch of them – but not sure what the state is. I think @burke has admin access and I don’t know who else.

I added @dkayiwa to ITSM in Desk.com.

FYI - @pascal, @surangak, and @jeffneiman also have admin access to Desk.com.

1 Like

Just send me a message if you need me to do anything specific on Desk. I’ll try and check in each day to make sure requests are being pushed/answered to/by the right people. Also, @ivange94, @hilz041, and newer volunteers @ddmaker and @tendomart might be able to commit more time to help ease the burden!

Heads-up, I’ve been trying to use formage to close helpdesk requests (new users and jira/wiki access) for almost 4 days now. I’ve already tried more than 20 times on a certain user, and still only times out.

I need someone to actually investigate the problem, restart the services, do whatever is needed to sort this problem out (I won’t have time until the weekend).

It’s a pretty bad situation that our ID is so unstable that we cannot edit users after so many attempts. Any help is appreciated.

I’m trying to fix SSO with Atlas and hopefully with Desk. Once that’s done – I’ll attempt the upgrade again. After that, I’ll stick around if anything breaks…but somebody else needs to take over once I deploy it and things stabilize.

I restarted the OpenLDAP container and ID Dashboard…let’s see what this does.

@r0bby i still get “LDAPError: Timeout”. After making a number of attempts, i once in a while get “LDAPError: Strong(er) authentication required”. And then back to “LDAPError: Timeout”. The cycle continues. Not a single attempt has so far succeeded.

Once you deploy and things stabilize, am ready to take it over, as we look for some one else. Therefore, feel free to point me to any resources that you think will be useful to get me up to speed. :slight_smile:

Fixed it – you should be able to do it – may need to try multiple times

What exactly do we need to do to avoid the need for trying multiple times? It does not feel normal.

I’m not sure entirely – but it’s gonna be hit or miss – I made edits and it worked the first time, sometimes I’ve had to try between 2 and 5 times…usually only have to do it on average maybe 3 times (now that it’s working normally) – the issue was due to me making an edit in the code and Dashboard wasn’t connecting to the server properly. This was 100% my fault – the issues you were having – in an effort to fix the problem, I made it worse.

All have PM’s here on Talk – I need access to debug what the heck is going on… it’s so weird.

Hello @jeffneiman and @burke Iwish to give a hand in all OpenMRS ID ,JIRA and confluence related matters to start with. All I need is resources to guide me concerning that,Help desk login and permission.

I appreciate all your services .

once you’re added to the ITSM team…you’ll see the queues I set up…should be straight forward