Errors when running mvn clean install openmrs-sdk

Hello community. I finished making changes on an introductory ticket then I ran mvn clean install. I get the following errors. Please help.

Sorry is this module updated to master branch, you can share the full log after trying mvn clean install -U


Thank you @sharif.Yes it is updated to master branch. This is what happens after running mvn clean install -U.

Sorry I pasted empty pastebin. Here is the log now

Here is what you needed to share

@isamanya What is the output of mvn -v?

1 Like

Thank you @sharif. @ibacher the output of mvn -v is

$ mvn -v Apache Maven 3.6.3 (cecedd343002696d0abb50b32b541b8a6ba2883f) Maven home: C:\Program Files\apache-maven-3.6.3-bin\apache-maven-3.6.3 Java version: 14.0.1, vendor: Oracle Corporation, runtime: C:\Program Files\Java\jdk Default locale: en_US, platform encoding: Cp1252 OS name: “windows 10”, version: “10.0”, arch: “amd64”, family: “windows”

Could you install the JDK for Java 8 and try building with that? Currently we’re a bit tied to Java 8.

1 Like

Thanks @ibacher. I have installed the JDK for Java 8. This is what happens after running mvn clean install

I have not yet successfully run the mvn clean install. I keep getting errors after trying for several days now. Please help @ibacher@ @dkayiwa.

The full log is at

Did you first run this module before making any changes??, You can share the pr and the ticket with your changes there should be a problem i guess

Hi @isamanya,

Please see this: Failed to execute goal de.saumya.mojo:gem-maven-plugin:1.1.5:exec (default) on project referenceapplication-omod

Thanks @sharif.

Thanks @sharif. I didn’t run the module before making the changes. It’s my first ticket at OpenMRS. and it’s RA-1806.

Thanks @tahira. I went through the posts earlier on and tried the solutions suggested there but I was unsuccessful.

@isamanya can you share the new error log after trying out the suggestions in the link that @tahira sent?

@dkayiwa, here it is (after running mvn clean install -DskipTests=true) running mvn clean install)

I did not change anything in the pom.xml because in it I did not find the piece of code that was being talked about in the posts.

Compiling through the command prompt as suggested was not successful as it gave this output

Is running mvn clean install -DskipTests=true and running through command prompt the only advice that you got from that thread?

@isamanya when using the command prompt, you need to go in the specific module directory and then execute the command

@isamanya also try the other suggestions from that thread like removing the space from path. ‘Openmrs ticket for work’ rename it to ‘Openmrsticketforwork’, internet connectivity, checking and removing the code from pom file etc.

@dkayiwa they are not the only ones. I thought I had tried all but like @tahira has advised I had some gaps and I need to try out some options still that I had not realized. Thanks alot for your support