error while running the openmrs server

After installing openmrs-2.7.0 SNAPSHOT of 2.x distribution `` i run it and it was successful but when i put the url on browser error appears as shown below

@sharif @jonathan @dkayiwa @ibacher @jayasanka

1 Like

Which java version are you using and which kind of installations, is it docker, or using SDK ?

java version 8

And this , is it SDK ?

using openmrs sdk

Basing on the logs, There is a problem with liquibase changeset, i dont understand when you say you run it successfull and you are still seeing such logs. Feel free share full log.

Thats not a full log. go to command line, copy full log and share it using Question, is your mysql server running in the background. Are you able to connect to your server well.

1 Like

@tumumanyenelson can you run the SDK setup again with this command? mvn openmrs-sdk:setup -DdbSql=null

it successfully passed but it shows that there was error while updating Thanks for help sir

1 Like

Me too getting this error. I tried with mvn openmrs-sdk:setup -DdbSql=null but it’s also returning an error. How to fix this error?

1 Like

First check jdk version

I checked it.

C:\Users\Acer>java -version java version "1.8.0_202" Java(TM) SE Runtime Environment (build 1.8.0_202-b08) Java HotSpot(TM) 64-Bit Server VM (build 25.202-b08, mixed mode)

C:\Users\Acer>mvn -v Apache Maven 3.9.7 (8b094c9513efc1b9ce2d952b3b9c8eaedaf8cbf0) Maven home: C:\apache-maven-3.9.7 Java version: 1.8.0_202, vendor: Oracle Corporation, runtime: C:\Program Files\Java\jdk1.8.0_202\jre Default locale: en_US, platform encoding: Cp1252 OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"

i was also getting this problem but we try this, delete the openmnrs server database in your mysql database server and create new server and make sure your mysql sever is running also donot forget to delete the current openmnrs server in your repository

Yes i already tried deleting db and openmrs folder. But error still getting in new server.

you should the mysql server version of above 5 and you should first choose the older version of the server

yes i did that also

Did you get a solution @tjayasinghe

no not yet. problem still exists.

@dkayiwa can you look at this? Mr. @tjayasinghe is a Senior Software Engineer for Science Land IT, the main vendor for OpenMRS service provision for the Ministry of Health in Sri Lanka. They have been asking how they can help contribute to the community, and we suggested they share on talk any issues they’re running into - so, would be awesome if you can help troubleshoot this Platform 2.7 issue :slight_smile: (I would ticket it but I might leave that to you in case you see an easy fix for this)

1 Like