Error while running openmrs-core from netbeans IDE using GlassFish server 4.1

Hello Everyone, I am using:

  • OpenMRS Core 2.4.0 Installation Wizard
  • Reference Application - 2.9.0
  • Netbeans IDE 8.02
  • GlassFish Server Open Source Edition 4.1

While I running the webapp from Netbeans IDE, the GlassFish server generates this error

Please help me?

Are you using a maven plugin for glassfish server?

By default OpenMRS-core has been configured to make use of jetty server’s plugin for deployment using mvn jetty:run from the webapp directory of core repo after running mvn clean install from core directory.

I don’t use maven plugin for glassfish server but when I run mvn jetty:run command from command prompt jetty server failed to start. When I run the webapp another error is displayed by the chrome browser. See the screenshot below.

jetty server error

GlassFish server error

Did you get a chance to look at this?

I have followed sort of steps from the above link, but after I run this mvn clean install openmrs-SDK: run -DserverId=your_server_id I got this error from a command prompt.

Do it from another folder which does not contain the openmrs-core source code.

I have run the command from C:\Users\Admin> which does not contain the openmrs-core source code but still displays…BUILD FAILURE error in the command prompt.

It greatly helps to always share the build failure log details instead of just the summary.