Error While installing the Bahmni

Tags: #<Tag:0x00007ff4c349c518>

I am installing Bahmni and got the error as per attached screenshot. Any solutions what i am missing on this.

Try installing MX dependency for OpenERP and run Bahmni install again.

-Execute the following command to install the dependencies:

yum install -y ftp://195.220.108.108/linux/Mandriva/devel/cooker/x86_64/media/contrib/release/mx-1.4.5-1-mdv2012.0.x86_64.rpm

1 Like

Solved. Thank you :slight_smile:

ftp://195.220.108.108/linux/Mandriva/devel/cooker/x86_64/media/contrib/release/mx-1.4.5-1-mdv2012.0.x86_64.rpm This link does not work any more.

Hi @webster, Can you check again now. I could see its working.

1 Like

I tried again. This is what I’m getting: Cannot open: ftp://195.220.108.108/linux/Mandriva/devel/cooker/x86_64/media/contrib/release/mx-1.4.5-1-mdv2012.0.x86_64.rpm. Skipping. Error: Nothing to do [root@bahmniserver ~]#

@rubailly, @binduak, I had to put HTTP:// instead of FTP:// for this to work. ftp://195.220.108.108/linux/Mandriva/devel/cooker/x86_64/media/contrib/release/mx-1.4.5-1-mdv2012.0.x86_64.rpm.

I too got above error. Using “http” in place of “ftp” did not work either. I then searched for the rpm file (mx-1.4.5-1-mdv2012.0.x86_64.rpm) on http://rpm.pbone.net/ (FTP search). It found it at a few other URLs. I checked one of them and confirmed it was working. I then added configurable installation variable mx_download_url to my /etc/bahmni-installer/setup.yml file and set its value to the working URL. Then ran bahmni install again. It then completed successfully.

The URL that worked for me is:

mx_download_url: ftp://ftp.icm.edu.pl/vol/rzm3/linux-mandriva/devel/cooker/x86_64/media/contrib/release/mx-1.4.5-1-mdv2012.0.x86_64.rpm

Can anyone of you please help me to find the latest mx_download_url

Yes, I knew there’s new bahmni version available but my machine is in critical condition in which i cannot update it blindly it’s been attacked by daemon threats , I tried to remove the threats but there was no success.So the other way out was to replicate the system onto other machine having same configurations.

Now I am trying setup that other machine but I am getting this error while installation. PLEASE HELP !!!

You can download from ftp://ftp.pbone.net/mirror/carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/devel/cooker/i586/media/contrib/release/mx-1.4.5-1-mdv2012.0.i586.rpm

Also in setup.yml, you can make an entry like

mx_download_url: ftp://ftp.pbone.net/mirror/carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/devel/cooker/i586/media/contrib/release/mx-1.4.5-1-mdv2012.0.i586.rpm

Notice the space after the colon

@binduak ^

Thanks, angshu…It worked @angshuonline you are just like google for us, Let us throw any issues but you always have solution for it. Thank you very much Angshu again.

Thanks to @binduak really. we are happy to help.

Old mx versionmx-1.4.5-1-mdv2012.0.x86_64.rpm.txt (104.5 KB)