Error when setting the Date of Birth

Hi there,

I’m having the following issue with setting the Date of Birth for a new Patient:

I am using the default date picker but I still get an error Please select a valid birthdate or age.

Any help greatly appreciated. Mick

Which browser are you using? Do you still get the same error when you use a different one?

Thanks @dkayiwa, I tried with both Google Chrome and Firefox and I get the same error.

I am working on a linux computer (if that makes a difference).


What is your currently selected locale in OpenMRS?

My locale is set to the default en_GB

Does it work if you fill in the Age instead of Birthdate?

If I fill in Age it brings me to the shortPatientForm.form page. When I try to save on that page I get the same error Birthdate is an invalid Date.

Bump…any idea on how to solve this issue? I tried on a Windows machine with Chrome & MS Edge but still the same result.

Can you share your server side log at

Great, thanks. Here is the pastebin from my catalina.out.

It works on my local machine but when I upload to AWS EC2 Instance, I have errors picking dates.

Which version of Java are you running?

Good point, I was running JRE but now I switched to Java 8

$ java -version
openjdk version "1.8.0_222"
OpenJDK Runtime Environment (build 1.8.0_222-8u222-b10-1ubuntu1~18.04.1-b10)
OpenJDK 64-Bit Server VM (build 25.222-b10, mixed mode)

I restarted TomCat but get the same error.

What is the time zone setting of the server?

It’s in Amazon’s eu-west-1 region. UTC timezone.

Is it the same time zone as on your local machine?

No, my local machine is EDT timezone. Do I need to build the war file on a machine in the same timezone?

Just for troubleshooting purposes, can you temporarily change your local time zone to that of the server and see what happens?

I tried changing the server timezone to the same timezone as my local machine. I restarted tomcat but I still get the same error.

(thanks for all your help so far on this Daniel!)

And which version of the openmrs platform and legacyui module are you running?

OpenMRS Version:    2.4.0 SNAPSHOT Build dc9937
Legacy UI Module	1.5.0