Error when running "mvn openmrs-sdk:run" command

I started getting this error after I run “mvn openmrs-sdk:run” command recently, I had no errors in the previous attempts last week. Error 1

Then I made a new server and got this error. Error 2

I need some help to fix this

Thank you

We are encountering the same error too. Please anyone with useful information on how we can bypass using the version of SQL connector that causes this problem should assist us.

1 Like

What happens when you stop the sdk and run it again?

Still the same experience even after restarting my computer.

As highlighted in the above image, The server time zone value ‘W. Central Africa Standard Ti’ is unrecognized it makes the dev server instance to crash but if i set serverTimezone=UTC in connection.url, the instance will load some pages and some pages will throw HTTP status 500 error as earlier reported by @sumedha.

I re-ran the SDK with a new server and i got the second error

Kindly share the second error using pastebin please!

1 Like

I was also getting a similar error here irynah@irynah-HP-Spectre-x360-Convertible-13-aw0xxx:~$ mvn openmrs-sdk:run[INF -

This started today. Last week I was able to spin the server using the SDK without errors. I tried running mvn openmrs-sdk:setup-sdk -U so as to upgrade my SDK but still the server could not start. I also realised that when I run this command mvn openmrs-sdk:run the server too k a bit long to start, there’s a bunch of stuff that run before indicating that OpenMRS is ready for you at http://localhost:8080/openmrs/ But I remembered @ibacher in his post talking about the upgrades he made to Openmrs-sdk. He also mentioned that if you still want to use the old SDK then run this command mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:4.1.1:run <usual arguments here if any> to start the server(ofcourse with modifications of the content in the angle (<>) brackets.

Following his advice I have been able to successfully start my server with the old SDK. cc @smarthech and @sumedha . This could be of great help to you as well.

cc @jwnasambu , @dkayiwa

1 Like

@irenyak1 Thanks so much for sharing this.

1 Like

this works like a charm, thanks @irenyak1

1 Like

@mherman22 so are you charmed? :slight_smile:

1 Like

Thank you @irenyak1, @ibacher and everyone that has helped in one way the other. I am super excited to have my server up and running again.

There’s a link called Error 2 in the original post

Thank you @irenyak1 :grinning:

1 Like

After using the above command …sdk ran successfully but got an error when I clicked

error java.sql.SQLSyntaxErrorException: Unknown column 'diagnosis0_.rank' in 'field li -

And why sdk not stable when I used mvn openmrs-sdk:run …it runs but also shows

any help please @tendomart

Thanks @jonathan for reporting this. Can you create a reference application ticket for it?

@dkayiwa [RA-1980] "FindPatient Page" doesn't show "Patient Page" when a patient is selected - OpenMRS Issues is it in good shape for Ready for work

@jonathan the way you described it is not enough for any one to reproduce. I do not believe that one can reproduce with version 2.12.0 of the reference application.

getting things breaking with the sdk,trying out these lines too

@irenyak1 this is what is working,it looks like we might need to update a few things around our documentation for this cc @dkayiwa

Have updated @dkayiwa hope it now ready I dive into it