Error trying to package htmlformentryui module 1.3 version

I managed to make omod file from the 1.6 SnapShot version of the htmlformentryui module. I am unable to do the same for the 1.3 version. What should I do to solve this?

I am using java - 7 and maven 3.3.9

Link :

In the POM file, change the reference application distro version from 2.3-SNAPSHOT to 2.3

This is the pom file, I cannot find such an entry :confused:

I’m curious as to why you have to build an old version of the module, why not just download version 1.3 from the module repository?

@wyclif your concern is obvious. Let me clarify my situation. If you seems to have some effective method to solve this issue, please be kind enough to let me know.

As you might know I have been working with the project to upgrade the data collection for Human Genetics Unit. Currently there are forms created which works fine with the older version of the OpenMRS GUI. My work is to upgrade this to the new one.

There is a third party software which has been integrated to the HTML Form via adding js librar dependecies, it was done with the older version via adding dependencies to the HTMLFormEntry.jsp file which is in the htmlformentry folder.

When it comes to the new GUI, it loads .gsp files for the GUI which are in the pages folder in the htmlformentryui. I tried adding dependencies to these files via changing them after the system has been deployed(this method worked when I edited the HTMLFormEntry.jsp files in the earlier GUI). But this method failed and I could not get the functionality as before. I checked the web site when is loaded via developer tools, but I could not find any dependencies I linked.

So I thought of embedding the dependencies to the htmlformentryui source and building that. I could build the 1.6 version but it was not compatible with the stand alone version, so I had to revert back to the 1.3 version(the one used in the OpenMRS stand alone version), then I got this error. :frowning: