error starting all openmrs modules

Tags: #<Tag:0x00007f0f19ddce60>

Module: (all latest modules.) System Version: (2.2.0)

Issue or Question:

(the web page appear blank without necessary interface like adding patient and other settings, I installed different versions and still get the same error.)

First click mark all as Read, click Administration>>> legacyUi page >>> manage Module>> click startAll button, and refresh the page

1 Like

thank you very much for your reply

it keep getting the error what is the basic modules to get an interface like

I am working on standalone 2.2.0 Is there any steps necessary to implemnt the module other than downloading them and putting them in openmrs-standalone-2.2.0\appdata\modules directory

and all I get is this

@aliattia can you share your full log using pastebin.com, Again what is your use case firstly

1 Like

starting module error has been fixed Thank you but I keep getting this blank page

I want to Implement an EMR system for outpatient clinic this is the modules which i have installed is there any other thing needed

Can you try to run openmrs standalone 2.10.0 which is the stable version and it comes with many bundled module . Again your use case is inefficient kindly describe your use case since you have succcesfully run the openmrs instance

I’m a pharmacist in the middle of implementing EMR system for patients in an outpatient clinic

I have downloaded the standalone version and I thought it would be enough but I got a blank page with no patient registration or any thing

I discovered that I got to download modules in order to get a page like that

but I still don’t know which modules to download as you mentioned I need a bundled modules I downloaded the bundled modules of 2.1 and put it in version 2.2 but it didn’t work so I’m going to download the app version 2.1 from here

https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_2.1/

Am I working in the right direction

Thanks for your time.

You are on the right direction however downloading openmrs platform_2.1 is more convenient for testing latest stable version of platform which i see wouldn’t be the case for the first time, i would advise to install https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Reference_Application_2.10.0/referenceapplication-standalone-2.10.0.zip/download. as a better option as per now for start.However you can include modules in your module folder but the first option will be fair

1 Like

@aliattia Any Progress so fur, we would love to hear from your progress upon installing openmrs

1 Like

Thanks bro

I downloaded the version 2.10.00 and its modules and started the program there was four errors due to missing modules I will download and add them Hoping to work

Many thanks

Ok thats good progress

1 Like

after downloading version 2.10.0

and adding bundled modules this error appeared to me

The following error occurred at startup:

Unable to start OpenMRS. Error thrown was: org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘validatorFactory’ defined in URL [jar:file:/C:/Users/HP/Downloads/ref%20app/referenceapplication-standalone-2.10.0/appdata/.openmrs-lib-cache/appframework/lib/appframework-api-2.14.0.jar!/moduleApplicationContext.xml]: Invocation of init method failed; nested exception is java.lang.NoClassDefFoundError: javax/xml/bind/JAXBException

is it related to Java version I use I’m using

java version “1.7.0_80” Java™ SE Runtime Environment (build 1.7.0_80-b15) Java HotSpot™ 64-Bit Server VM (build 24.80-b11, mixed mode)

Did you first run it before you include your modules. Can you share the full logs using pastebin.com.

1 Like

yes I did run it and it worked but it told me than no user interface module is installed

when i put the modules it gave me this error

https://pastebin.com/D1iwwVUC

and the full log is here

https://pastebin.com/kxSy71q8

Make sure your mysql server is running in the background, Also are you in position to upgrade your java to java8

Can you share your modules in folder openmrs-standalone2.10.0>> AppData>>Modules here such that we can be sure we are on the same track

I updated java to java version “1.8.0_251” Java™ SE Runtime Environment (build 1.8.0_251-b08) Java HotSpot™ 64-Bit Server VM (build 25.251-b08, mixed mode)

I 'm not sure of how to run mysql in the background i went to mysql.exe and mysqld.exe which are inside the openmrs folder and opened them

this the modules which i placed inside

referenceapplication-addons-2.10.0.zip

I think I have no chance with these version

the problem is when i Firstly downloaded the latest release 2.3.1 there was a problem in connecting database and it told me that the username and password are wrong

Thanks thats good, Can we have chat on https://www.uberconference.com/room/openmrs and we see way forward

OK I’m opening it

Hey @aliattia any progress?