error saving condition


(mona saleh) #1

Hi, I logged in as an admin --> to the pharmacy --> register patient --> add condition --> then got the error can’t save condition. I tried it with the date of today and date of tomorrow and I got the same error. I changed pharmacy to inpatient ward and got the same error. Any help plz :slight_smile: ?


(Juliet Wamalwa) #2

I think this is a wake up call I have tried several times since the release but it doesn’t work anyone to help fix please?


(Daniel Kayiwa) #3

@jwnasambu did you create a ticket for it?


(mona saleh) #4

sorry, I am new in this. How do I create a ticket?


(mona saleh) #5

I am adding this use case for a (patient counseling) pharmacist who is asked about an OTC (over the counter) medication, that is dispensed without the order of a physician. Do we have this use case in the current release of openMRS :slight_smile: ?


(tendo kiiza Martyn) #6

@monasaleh you may want to look at https://wiki.openmrs.org/display/docs/Tickets


(mona saleh) #7

Thanks a lot, I created a ticket at this link:


(tendo kiiza Martyn) #8

Great to hear !


(Daniel Kayiwa) #9

@monasaleh do you still get this error, if you get to your system’s equivalent of this page https://demo.openmrs.org/openmrs/admin/maintenance/settings.list and set the Default Locale to en


(John Mark Esplana) #10

I was having the same issue as described by @monasaleh but I followed the instructions provided @dkayiwa to change my system settings and set the Default Locale to en and it worked! I had it originally set to en_GB

Btw, i’m using Ref app 2.9 snapshot


(mona saleh) #11

Thanks for the reply. I tried it in the demo.openmrs.org and it worked just fine and successfully saved the new condition. But how can I do the locale in the downloaded reference application because it still does not save the condition?


(mona saleh) #12

I have (referenceapplication-standalone-2.8.0). How do I change the system settings? I am on ubuntu :slight_smile:


(mona saleh) #13

I thank you all. I have just read this topic:Unable to add new conditon and adjusted the locale. Thank you for your effort :slight_smile:


(tendo kiiza Martyn) #14

@monasaleh which system settings are you talking about ?


(mona saleh) #15

at this link: http://localhost:8081/openmrs-standalone/admin/maintenance/settings.list :slight_smile:


(tendo kiiza Martyn) #16

it is on your host , i cannot access it .


(mona saleh) #17

maybe you can try to type the path of the url in your standalone reference application. :slight_smile:


(tendo kiiza Martyn) #18

@monasaleh am running enterprise ,i don’t have standalone.


(mona saleh) #19

aha, I see. I do not know much about the enterprise edition