Error running reports: communication link failure


I am having issues with bahmni endTB reports. Error log is attached. Reports have been running since long and nothing has been changed in the system. I tried restarting various services including mysql and bahmni-reports service. I have also connected to bahmni_reports db from mysql command line interface, so apparently there are no connection issues.

I first encountered this issue on endTB 2.0.3 release. I then upgraded to 2.1.1 but still facing the same issue. Any help would be appreciated.

error running reports.pdf (217.7 KB)


Updated log file: error log.txt (23.1 KB)

Best, Wasim

Hi again,

Just in case someone stumble on this thread looking for solution, my issue was fixed by adding following variables to mysql conf file /etc/my.cnf

wait_timeout = number
interactive_timeout = number

For further details please look at this stackoverflow thread. There are other solutions that worked for some other people.

Best, Wasim

1 Like

Thanks for sharing your solution!

1 Like