Error on openmrs-core setup

So I wanted to work on my first issue in openmrs-core repo.
I am using

  • MySQL 5.7.
  • Java 1.8
  • maven 3.6
  • And windows power shell admin
  • Windows 10
  • cloned openmrs-core repo and the below was done on master branch.

I ran the commands mvn clean install and then in webapp folder i ran mvn jetty:run

The DB was getting installed. But I was not able to see the prograss bars. ( I checked in the workbench, openmrs DB was created)

I got a WARN : Unable to find openmrs-runtime.properties in webapp folder. And then the exec stopped.

so I manually copied the openmrs-runtime.properties file from %AppData% and pasted into webapp folder.

Then again I run the command mvn jetty:run This time I was not redirected to initial setup but this page.

So i downloaded reference app 2.11.0 Addons from Download OpenMRS | OpenMRS and pasted the modules and owa folders in the correct directory.

Then after doing mvn jetty:run .
I get the following error. It’s been a few days since this issue has been troubling me. Would be glad if anyone could help. :slight_smile:

I am tagging people who have recently committed to the repo hoping to get help faster @dkayiwa @gracebish @suubi7 @herbert24

Replace all those modules with these ones and restart OpenMRS.

1 Like

Hi @dkayiwa , I did what you asked, the following errors/warnings popped up at different points of the server log.

  • WARN - Listener.loadBundledModules(483) |2021-03-01T23:17:27,258| Bundled module folder doesn’t exist: F:\OpenMRS\openmrs-core\webapp\src\main\webapp\WEB-INF\bundledModules
  • WARN - ModuleFactory.startModuleInternal(783) |2021-03-01T23:17:35,565| Error while trying to start module: fhir2
  • WARN - Slf4jLogger.warning(32) |2021-03-01T23:17:28,769| Failed to restore the auto commit to true
  • WARN - HibernateUserDAO.getUserByUsername(112) |2021-03-01T23:22:30,338| request for username ‘scheduler’ not found
  • WARN - AbstractTableMetaData.getDataTypeFactory(166) |2021-03-01T23:21:09,767| Potential problem found: The configured data type factory 'class

and many more, all are pasted in detail here.

Are these warnings normal ? Or are these serious errors ?

Also despite all these the UI loaded and I was able to login… Thanks a lot @dkayiwa for the link.

2 Likes