Error occurred at startup for Standalone OpenMRS

I am trying to install the standalone OpenMRS on my Ubuntu virtual box, and I have Java 14.0.2 installed. I have the zip file decompressed and have been able to run the .jar file. However, while OpenMRS is installing I get the following error:

The following error occurred at startup: Error occurred while trying to get the updates needed for the database. Unable to get a connection to the database. Please check your openmrs runtime properties file and make sure you have the correct connection.username and connection.password set.

I have seen others post about this same error but haven’t been able to correct it on my system. I have located the file with connection.username and connection.password, I just don’t know what I am supposed to change them to to correct the error (if that is the true source of the error). The other responses to this error discuss using your mySQL username and password, but I thought for the standalone version, you didn’t need to have mySQL installed (though I do have it installed). I appreciate any insight any of you may have!

More output at:

@dedrickt you can also have a look at this reference Error: Please check your OpenMRS runtime properties file and make sure you have the correct connection.username and connection.password set

@dedrickt make sure that your local mysql instance is off before running the standalone jar file because the openmrs standalone comes when its bundled with its own mysql

The version that you are running requires Java 8

1 Like

@dkayiwa Thank you for your response, I switched my Java version to 8 and still have had the same error

@gcliff thanks for the suggestion, I tried this and unfortunately did not solve the problem. I have also checked out the link you provided to see a similar error that someone else had in the past. I am not sure that the solution will help me because it seems that the person who had that error was installing a different version of OpenMRS, I am trying to download the standalone and therefore am not sure what to do when they discuss checking their mySQL instance.

I’m not sure what the error truly was, however I was able to finally get into the OpenMRS standalone installation after restarting the process by redownloading the package.

@dedrickt sounds awesome :+1:

1 Like