ERROR: redirected you too many times.

Hello, I found what is potentially a bug, with OpenMRS. I appreciate your evaluation. This bug shows on our implementation as well as the demo server.

To generate this potential bug please do the following:

This page isn’t working redirected you too many times. Try clearing your cookies. ERR_TOO_MANY_REDIRECTS

I appreciate your advice.


1 Like

You are correct, this is a bug. Can you search on in the RA project to see if it has been reported already, and if not, create a new ticket?

(Of course you’re also welcome to submit a fix!)

Thanks @darius

Here it is

@yadamz and @darius I see that this hasn’t been worked on in a long time.

I’ve looked into the issue a bit and it seems that when a user is logged in and he tries to visit the demo url in a new tab, it should redirect to but ends up redirecting to instead. A simple fix in the redirection script or the DNS configuration should do the trick, shouldn’t it?

Hi @dkayiwa @darius I’ve worked on the issue and have submitted the pull request here -

  1. However I am unable to change the status in JIRA from ‘Waiting for Test’ to ‘Code Review’. Any help on the matter?

  2. I had some other queries on the matter as well. Cause this redirection issue shouldn’t have happened in the first place according to existing code. It would be great if we can have a discussion with people who’ve originally worked on the reference-application module.

You can always initiate a discussion on Talk.

Sure. I’ll do that regarding point number 2.

But how about point 1. I apologize if it sounds like a stupid query, I’m quite new to JIRA.

The Reference Application JIRA project does not have a Code Review state in its workflow.

Oh. So how should the ‘Waiting for Test’ be handled? Also to @ssmusoke

If your pull request ready for testing?

Yes, it is ready.

@dkayiwa Hi. As I’ve mentioned, the PR is ready for testing. Should I Create a Zephyr Test? I’m sorry for bothering over the issue :sweat_smile: It’s just that it effects all ref app versions till now and I think the PR has the resolution. Needed a second eye to validate. :slightly_smiling_face:

No need for the Zephyr test. Have you tried to review other peoples’ pull requests?

You mean Code Reviews? Yes. I’ve done 2 till now. On the following PRs -

I’ve submitted my own PR for this issue. But since Ref App doesn’t have a Code Review stage, its stuck in ‘Waiting for Test’.