Error creating BIRT Report with patient data


I’m having a strange report error. When i run the BIRST report without patient data in the system, it runs well. but when i add patient data, i get the following error:

I have been using this same report for a while now and don’t know what might be causing the error

Any leads?


Can you share the full stack trace as it appears in the tomcat log?

Here’s the full stack trace

Did you get this from the tomcat log? Or is this all your tomcat log gas? It does not seem to have the root cause.

I found this in one of the catalina logs

Make sure that the database connection in the report definition file is pointing to a running instance of the database.

The dB connection definitions are pointing to the right instance, running on the localhost. Anything I should look out for?

Sorry for the confusion. This is the actual error for the report

Are you using the restrictbyrole module for anything?

1 Like

Yes. I realized it’s the cause. But Even when i unoad it, it seems to persist. I tried running the report before loading the restrictbyrole module and it had the same issue.

Lemme confirm first


Yeah. The module was causing the issues. Thanks foe highlight Daniel

Most appreciated