error after installing OpenMRS 2.5

Hello, after installing OpenMRS 2.5 WAR 2.0.1 (JAVA 8 , TOMCAT 1.8) . Everything was fine. I tried to restore my databse from previous installation (WAR 1.11.5, RefApp 2.3) . Once the restoration completed I tried to login and I got the following error:

Any help to review what I did wrong is much appreciated

When restoring a database from a backup, you need to restore to the exact version as the one you used to backup. In this case, you need to restore to platform (WAR 1.11.5, RefApp 2.3), then upgrade to OpenMRS 2.5 WAR 2.0.1 (JAVA 8 , TOMCAT 1.8)

I C … I will do so

Hello @dkayiwa

I am still struggling with the update. I could not start Metadata mapping module 1.2.1 The error message is as follows

Error while trying to start module Unable to update data model using liquibase.xml. Module: Metadata Mapping

Any idea?

I cannot tell without looking at the tomcat log.

Hello @dkayiwa

here is it

When you restored the backup, did you also restore the old modules before the upgrade?

@dkayiwa I Used the new modules from 2.5 … I did not use the old ones

For the database restoration, you need to use the old platform and modules. After all is working as before, you then do the upgrade.

@dkayiwa so what I did is restoring my old database to my previous platform . Then undeploy WAR and delete modules … deploy new WAR (openMRS worked fine before uploading new modules ) and then upload the new modules … most of the modules worked fine except data mapping and all modules depending on it

You could be facing exactly the same as here: Drop the metadatamapping_idx_mdtm_mdclass index from the metadatamapping_metadata_term_mapping table and try again.

@dkayiwa I think it it the same problem … How do I do that though … Is it a command on MySQL ?

You could do it using any MySQL GUI or execute a command on the terminal. Just google how to drop a mysql index