Eclipse hierarchy of the type error

I’m trying to write tests for a rest resource I created but I’m getting this error on the eclipse IDE “The hierarchy of the type AutoGenerationOptionResourceTest is inconsistent” when I tried extending BaseDelegatingResourceTest. anyone with any solution to this :slight_smile:

@kwahalf can you please gie us a detailed log at :wink:

when I do mvn run test this is the error I get @tendomart

@kwahalf your log seems to suggest that some instances are being used in your code but not imported into your class,the compiler cannot carry out compilation when an instance being used is not imported…try looking through the surefire reports folder to track the exact cause,the snapshot has lest out some information…

@kwahalf from the maven build log it looks like there is an issue with 2 files:



Delete or Rename these files because it seems that they are not in the correct state.

In your eclipse project, right click the project folder choose Maven then choose Update Project… Choose all necessary projects then update.

The jar files should be recreated properly.

You should now be able to run mvn build.

Thanks @adams It worked :wink: