Download from github and compile HTML Form entry don't work

Platform Version: 1.11.4 OpenMRS Version: 2.1

Question: Hi all,

I have the same problem that it describes here. I tried the solution that says about the HTML Widgets module, and the problem persists, then when I tried the proposed solution of HTML Form Entry Module, I have the following errors:

When I import the module from github and after import as a Maven project, I receive the following alert:

maven-openmrs-plugin:1.0.1:initialize-module (1 errors)

No marketplace entries found to handle maven-openmrs-plugin:1.0.1:initialize-module in Eclipse. Please see Help for more information.

I tried do this with differents branches but the result always is the same

And when I run the omod folder as Maven install I receive the following error:

[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.643 s
[INFO] Finished at: 2015-08-12T16:57:51-05:00
[INFO] Final Memory: 6M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project htmlformentry-omod: Could not resolve dependencies for project org.openmrs.module:htmlformentry-omod:jar:2.5-SNAPSHOT: The following artifacts could not be resolved: org.openmrs.module:htmlformentry-api:jar:2.5-SNAPSHOT, org.openmrs.module:htmlformentry-api-1.10:jar:2.5-SNAPSHOT: Failure to find org.openmrs.module:htmlformentry-api:jar:2.5-SNAPSHOT in was cached in the local repository, resolution will not be reattempted until the update interval of openmrs-repo has elapsed or updates are forced -> [Help 1]

This never happened to me with other modules.

I need that the module can compile urgently…

If anyone knows the solution and can help me, I would be very grateful. Thanks!