Does exitFromCare Tag Work on OpenMRS 2.x UI?

Tags: #<Tag:0x00007fddfa644f80>

Does the exitFromCare tag work on OpenMRS 2.x UI? I’ve tried setting the global property concept.reasonExitedCare to CIEL: 6098 and then selecting a Reason for Exit but the encounter is not saved. Might I be using the wrong concept? Also seems the “Choose the Cause of Death” drop down is always displayed even when the Reason for Exit is not death of the patient.

@whiscard, peeking at the code, I see that there is some jQuery code which would not work with Reference Application 2.x.

Someone would need to make some code changes to fix this bug; do you have dev capacity for this? (If so, then someone can give pointers as to what changes need to be made.)

You can test out the form in the legacy UI to make sure you’ve configured things correctly (and verify that the bug is in the 2.x refapp UI).

Thanks for the feedback @darius

On the Legacy UI, when I choose Reason For Excited Care as Deceased CIEL:159, The additional Cause of Death Drop down is not displayed:

I’m however able to save the encounter on the legacy UI:

We currently dont have the Dev resources but it would be helpful to know how this can be fixed incase we get a Dev resource or someone that can take this up.

Thanks.

@whiscard can you start by creating a ticket for this? Remember to mention the ticket number here.

@dkayiwa, Noted, thanks. Please see the details of the ticket here: https://issues.openmrs.org/browse/HTML-650

Great. Now are you able to get a dev resource to work on it?

Sadly not yet. We are currently held up for most of this month and next.

@whiscard can you post on the talk developer category and ask for volunteers?

Any Volunteers able to take up this ticket?

https://issues.openmrs.org/browse/HTML-650

@whiscard this category is for implementers. You need to post to the developers category explaining what kind of help you would like them to offer, and give them some kind of back ground. :slight_smile:

@dkayiwa I thought I changed the category to Development :slight_smile: Ok, I’ll create another post. Thanks.

@whiscard i have seen the post you have just made in the developers’ category. Your link for the ticket does not look correct. Can you cross check?

Yes you were right @dkayiwa. Fixed the typo :slight_smile:

helo @whiscard been working on the ticket that u created but am having a challenge with reproducing the bug concerning the htmlform entry reference tag, i need some assistance…

@mogoodrich @mksd