Dockerizing development and deployment of OpenMRS

,

I’ve just discovered that this has been already addressed by @ibacher. So the plan is triggered whenever changes to O3 components are made and everything is being deployed. Thanks @ibacher!

2 Likes

I know you’ve seen this, @raff, but I want to ensure this Talk thread gets linked to a related discussion on Talk:

1 Like

Hello @raff, Bahmni team is using openmrs/openmrs-distro-platform:2.5.7 as the base image and we have enabled multi-architecture builds in Github Actions. The builds are successful and the docker images have both the architectures now. But still OpenMRS is not coming up properly on Mac M1 machines. We have also tried openmrs/openmrs-distro-platform:2.5.7 image on M1 but that too didn’t start. Do you have any suggestions/ experiences on running OpenMRS containers in Mac M1? Would you suggest trying out any other base image on M1 ?

cc. @gsluthra @angshuonline @binduak @shobanadevi @n0man @mradul.jain

Thanks.

2 Likes

@mohant Could you please share logs? Have you seen O3: M1 machine support - #8 by dkayiwa ?

Basically try increasing available memory and make sure not to hit any REST endpoints before fully started up due to an issue with the backend.

I’m able to run with 8 GB of memory, 4 vCPUs, 1 GB swap, 160 GB disk image size.

2 Likes

@raff I have 7.90 GB memory, 5 CPUs, 1GB swap and 59.6 GB disk image. Earlier i was able to run openmrs even with lesser memory, CPU and disk image than this. Will try with what you have suggested and update.

@raff tried with this storage(8GB memory, CPU -6, swap 1GB, Disk image size 160GB) and still openmrs is not up. shared logs openmrs.txt (21.0 KB) Could you pls check?

@shobanadevi from the logs it seems as if you have started plain platform and it’s up and running. No unexpected issues. The two errors are bugs in webservices.rest / owa, but they do not affect the system. Did you start it up from GitHub - openmrs/openmrs-distro-platform: This project is used to package the core OpenMRS war file with bundled modules ? If yes, then you should be able to access it via http://localhost:8080/openmrs. Otherwise please share steps to reproduce your issue and how you conclude it is not working.

1 Like

Could you say something about that bug? I’ve actually been using, e.g., http://localhost:8080/openmrs/ws/rest/v1/session to check whether the app is up or not…

Hiwigo: [RA-1769] Calling REST API during initialization break Reference Application - OpenMRS Issues

@raff Thank you. yes it is working now by accessing with url http://localhost:8080/openmrs.