Docker image 3.x

l do not know why I can not able to see it. I am giving an attachment for an idea of what kind of error.

Also, I am giving my server public IP anybody can access openmrs.

Please give suggestions! Thank you

Oh! Sorry… you must have a slightly different version of the Docker command line tools than I do… try replacing docker compose with docker-compose

Thank you so much for your respoend. I follow

your guideline. Please see the attachment and let me know what should I do?

So, this logging is telling you that openmrs didn’t start-up because it couldn’t connect to the database. And next to openmrs_db_1 I see that the state is Exit 1, which indicates there was some kind of error starting the database.

Could you please show the output of docker-compose logs db?

Sorry for the

late response. I got another problem would you take a look? Please advise me of the solution. Thanks

This is probably the same issue as above. The way the images work, there are three servers: the server with the frontend files, one with the openmrs backend and one with a proxy that routes requests to the other two servers as appropriate. A 502 Bad Gateway error usually means that the proxy tried to proxy a request to a server but the server wasn’t available. In this case, it looks like the OpenMRS backend is not available (since the frontend loads, but the request to the REST API fails).

The root cause is probably the same as whatever was causing the issue before, so my ask is still the same:

Hello All,

I need help configuring oracle cloud Docker images openmrs 3. x install. If is anybody interested help me I will pay for your time. if you interest please let me know. Thanks!