Distro 2.4-SNAPSHOT depending on Platform 2.0.0-beta... overnight??

Hey all,

So this morning, I run my first mvn clean install on the module that I’m currently developing, and without any changes since last time I ran it (yesterday evening) the build failed. mvn dependency:tree shows me straight away that I depend now on Platform 2.0.0-beta all of a sudden…

First of all, one remark: I depend on 2.4-SNAPSHOT because I cannot depend on 2.3 anymore (see my remark on this thread). So now that I am stuck with depending on 2.4-SNAPSHOT I have to be at risk that anything can change overnight. And moving to Platform 2.0.0-beta is a bigger change than usual.

So here are the steps that I had to take to keep building my module:

  1. @Ignore the unit test of the artifact-generated service (in api: MyModuleServiceTest.java). It is looking for the class AbstractReportObject from openmrs-module-reportingcompatibility (this class used to be in core pre 2.0.0-beta), but LATEST or 1.5.9-SNAPSHOT are nowhere to be found on the Maven repo for that module. So I just gave up on that test. Any suggestions are welcome though!

  2. export JAVA_HOME=$(/usr/libexec/java_home -v 1.8) … but just for the sake of that build, the rest of my life still happens on Java 7.

  3. Finally mvn clean install

I then installed my module on my ‘2.3 instance’ that is still Jetty-run on Java 7 and it looks ok so far… (Q.) But is it really ok?

I don’t know if it was planned for distro 2.4-SNAPSHOT to depend on Platform 2.0.0, but if it was, then I think it definitely should still be possible for people to depend on distro 2.3.

@mksd can you try again to see if it still requires platform 2?

Dependency versions can’t change in the POM file just like that unless you configured your module in such a way that the versions are pulled from another project, did you set it up such that the versions are pulled from the reference application distro project or some other project? If it is the case, you might want to change that to avoid this in the future

@wyclif It’s still visible on the Maven repo: here. Look at all the files changed on Apr 26.

@dkayiwa, trying, will let you know in a bit…

@wyclif it was caused by my wrong setup of the platform 2.0 reference app distro. But should now be fixed.

Yes, and as I said I wanted to depend on distro 2.3 which is not possible anymore. So I have to depend on 2.4-SNAPSHOT and all of a sudden happened what I described in my initial post. (Q.) Can we confirm that distro 2.4 will not be based on Platform 2.0.0?

@dkayiwa, working now, thanks :ok_hand:

Yes is it confirmed that distro 2.4 will depend on platform 1.11.6

1 Like

That’s the downside of pulling dependencies from the distro if you don’t intend to keep up with it’s changes. You might want to manage your versions manually

Hi @dkayiwa!

Hi @wyclif!

Looks like this happened again: http://mavenrepo.openmrs.org/nexus/content/repositories/public/org/openmrs/distro/referenceapplication/2.4-SNAPSHOT/referenceapplication-2.4-20160616.203215-767.pom

Can’t build modules that depends on the distro 2.4-SNAPSHOT :confused:

I think the problem occurs after the “Distribution on Master” CI job runs. I re-ran the Distribution build and it appeared to fix the issue. @wyclif and @dkayiwa probably know more what the right long-term fix should be.

Take care, Mark

I have just made some changes to Distribution on Master to avoid this happening again.

Thanks Daniel!

Cool, it works now! Thanks @mogoodrich and @dkayiwa. :thumbsup: