Difficulty implementing OpenMRS Reference Application from scratch (OpenMRS Core)

I have had tried installing OpenMRS Reference Application with OpenMRS Core 2.5.x and 2.6.0 from scratch several times in the past few months and have not been successful each time.

Here are the consistent specifications:

  • Tomcat 9 (with manager-gui; without it, OpenMRS would not even start)
  • Java 11 (OpenJDK)
  • MySQL 5.7
  • Ubuntu 18.04 (has anyone here tried it to work on the latest Ubuntu or Debian versions?)

Here is the main problem after I install OpenMRS successfullly with the initial setup: I cannot get any extensions or OWA to work after uploading them all to the OpenMRS directory. If I try to put all reference application extensions at once after I unzip them to my home directory, OpenMRS freezes and renders a blank page (error 500) after 1 minute or so. I have had tried removing the offending extensions and restarting Tomcat each time, however, it still would not render. I eventually gave up and now, this Talk topic is here.

What are the proper steps to implement the Reference Application on a server implemented from scratch (i.e. with the Platform WAR’s latest versions)? Which extensions to install first?

In general, I’d just copy the modules to $OPENMRS_APPLICATION_DIRECTORY/modules and the OWAs into $OPENMRS_APPLICATION_DIRECTORY/owa and restart OpenMRS, where $OPENMRS_APPLICATION_DIRECTORY is the path to the runtime directory of OpenMRS. I don’t know that anyone would off-hand know the order you would need to load those modules in individually to get everything working as that’s not really something we do (even the RefApp itself is built using the process I mentioned above).

There’s no reason why it wouldn’t work as long as you can install Java 11, Tomcat 9 and a version of MySQL on it (for 2.4.0, we support MySQL 8 as well as 5.7).