Data quality widget not working

I’m stuck in the issue related to patient dashboard: DINT-77 . Data Quality Widget in the patient dashboard is not working in my machine. These are the changes I’ve made in the coreapps module: https://github.com/shivtej1505/openmrs-module-coreapps/commit/777d6749309378a463ff3032c92a48092aaea73a

It is supposed to be look like this:

But it is looking like this:

I think even other widget aren’t working properly.

@ssmusoke just in case you did not see this. :slight_smile:

@dkayiwa , thank but I already got in touch with @ssmusoke and he told me to ask Rafal for help. :slight_smile:

@raff , I’m facing a problem due to webpack. It seems like ui.includeJavascript fetching scripts from wrong location or webpack is saving compiled scripts in wrong location. There was 404 error on these scripts:

I’m using SNAPSHOT version of coreaps-module but still I’m facing the issue. When I copied the scripts generated in omod/target/classes/web/module/resources/scripts/web/ to omod/src/main/webapp/resources/scripts/web/ , everything worked fine. Could you please look into this ? Thanks :slight_smile:

@raff do you have any response to the above?

@shivtej, could you please paste the whole output from maven when doing ‘mvn clean install’ for the coreapps module?

Reading the DINT-77 issue it seems the regular build works for you, is that right? Are you having an issue with the watch command for development?

@raff , I added coreapps to watched project and it build without error and also npm run watch was working without any error but it looks like ui.includeJavascript picking scripts from wrong location. When I copied the generated scripts in that location all the widgets start working. That’s how I completed DINT-77 .

Here is the full log of mvn clean install on coreapps module - https://pastebin.com/NAMdDPrJ Thanks!

It should work, if you update uiframework to the latest (3.12.0-SNAPSHOT) as mentioned in the README:

For continous development we recommend setting up a server using OpenMRS SDK and adding the coreapps module to watched projects (supported in UI Framework 3.12.0+).

@raff, I did look for the version 3.12.0+ in the modules.openmrs.org but only found 3.11.0+ version there. I will clone the uiframework module and try again. I’ll let you know if that worked or not.

I guess we should update the README to mention the version specified is SNAPSHOT version or we can upload newer version on the modules.openmrs.org .

@shivtej, I’ll release 3.12.0 today once you confirm it works for you.

@raff, I tried this with the SNAPSHOT version and it worked nicely. I think you should release this version. Thanks for fixing it.

Released. @darius, @wyclif, @mogoodrich, could you please add me to maintainters of https://modules.openmrs.org/#/show/144/uiframework so I can upload it.

@raff sorry for the delay, I just made you a maintainer.

FYI the only way I know to do this (since it’s broken in the modulus UI) is to:

  • ssh into the machine
  • connect to mysql as root (with a password Cintia gave me, from our lp account)
  • (after selecting to find your user_id…)
  • insert into module_user (module_maintainers_id, user_id) values (144, 46);

It’ll be great when we switch to bintray!