Data Missing from spring-form.tld File

We are encountering an alarming issue which entails data getting lost untowardly from the file “spring-form.tld” which occurred for the first time in Fenchuganj Hospital on 18th May, 2021 first which was recovered using data dump, config file etc. but occurred again on 23rd May,2021. Same incident is reported again on 29th May,2021 in another hospital where operational intervention is least likely. We are struggling to diagnose the issue and since we are liable for administering all data-this is deeply ruffling us. We are avidly seeking support from the community for any potential diagnosis and resolution


What do you mean by data getting lost from the file spring-form.tld?

@dkayiwa Data becomes blank from the .tld file

openmrs.txt (748.4 KB)

Can you share a screenshot?

Have you seen the log file that I have shared here.

  1. There are 3 locations of the tag library

which one are you talking about?

As discussed in the PAT call, we have never faced this issue, and its highly unlikely that files under WEB-INF directory will be altered/modified at all. Only from JSP pages of respective modules would load up the tag libraries. So its little weird

  1. What version of Bahmni and OS are you using?

  2. If you are think that it’s relevant to “spring-form.tld” file change, I think logs may not be relevant to that. If this is the top of "/var/log/openmrs/openmrs.log), then its the indication of whats happening now. You need to check and analyse when and why it is happening. Have you checked all the other log files for any clue?

  3. If the system was running alright all the while, try to figure how what activities and changes has happened recently. Any updates / installations / commands - (including automated) - yum, rpms, jave/jre, modules, backup/restore scripts, cron jobs etc etc.

  4. Have you done any customisations over standard Bahmni? additional modules? additional scripts? Do you have custom modules deployed? If so, can you remove that module and try? Same for scripts

  5. Have you tried to co-relate the system logs (not just openmrs logs) to the time the system stopped working? Have you checked all commands executed that time?

  1. We have checked the three directories for the “spring-form.tld” file and we have got data existing in the files. It was our mistake primarily.
  2. We didn’t do any customizations over standard bahmni. We did have a custom module and that was deployed 6 months ago. We have tried removing our custom module, but the error is the same after restarting openmrs.
  3. We did observe the logs. In openmrs.log, we are facing the same error. Here is the log file openmrs.log
  4. Regularly we fire two script commands. i) backup script for databases ii) script for deleting cache