Customizing Openmrs / versions / data set

Hello everyone, I’m working on a project in which I should use openmrs. The aim is:

  • to have a dataset of patients (so I’m looking for a ready database or dataset to upload)
  • manage the module it offers to customize options like reporting, chart search, data correlation etc.

I’ve been trying to install different type of versions but still confused about what each one offers. Can’t get the one that meets my needs.

//reference app standalone version

1.1) When installing the reference application standalone, it is missing datasets which are not compatible according to what I read on the wiki page. (demodata)

1.2) I’ve tried to add modules but I always get a 'http 404 error: the requested resource is not available"

// plateform + legacy ui version

2.1) When installing the plateform version, it says user interface missing. I added the legacy but I got less interfaces than in version 1).

2.2) I’ve tried to create a patient but I get a permanent error: wrong birthdate type, however the type is correctly written.

2.3) I created an “openmrs” databse and added the demodata as source file, but when accessing openmrs, I can’t see records of patients. Is demodata only for the database structure? or is it also filled with information?

I’m still a newbie and I’d be glad if someone can help me with these questions. Thank you in advance! (my OS is windows 8, for the platform installation I used tomcat 8.5 and added openmrs war file)

@amenikh u can have a look at these

https://wiki.openmrs.org/display/docs/Reference+Application+2.10.0

https://wiki.openmrs.org/display/docs/Installing+OpenMRS

Thank you. I read related info to these pages, still not helping.

Can you please tell me what does the "demo data’ contain? is it just a database structure or does it have patients’ names and information etc? I need a ready dataset of patients and their information so that I can work on that. Where can I find it ?

demo data is a sample dataset containing patient info and their observations

take a look at this https://wiki.openmrs.org/display/RES/Demo+Data

I did visit that site before. I’ve tried installing different versions of openmrs. I uploaded the demo data. Also tried the “set demo data on next startup” option that was recommended on that same website. But in all these cases I can’t find any data when I access to openmrs. The patients list is empty. That’s driving me crazy. I don’t know what the problem is.

@amenikh did u set the set the setting named “referencedemodata.createDemoPatientsOnNextStartup” to the number of demo patients you want created and restarted the application.?

Yes, I already mentioned that above. I tried both ways and I restart each time but still can’t find any data

@dkayiwa kindly help weigh in on what could be the cause of an empty patient list when the demo data has uploaded?

What value do you have for “referencedemodata.createDemoPatientsOnNextStartup”?

Is the referencedemodata module installed and started?

the value of “referencedemodata.createDemoPatientsOnNextStartup” was 0. I changed it to 10. Restarted the module referencedemodata. Restarted tomcat. Still no data at all.

**

I even tried to use the platform version. I created a databse with source demodata.sql. But can’t find any data when I log in to openmrs.

I need a ready dataset so that I can start working on it. I think I will have to manually create patients. But that would be a large number and a lot of work :confused:

Set the value of referencedemodata.createDemoPatientsOnNextStartup to the value that you want. Stop the standalone. Delete its log. Restart the standalone. Then paste the contents of the log at pastebin.com after you have logged in.

I did. Here is the result : https://pastebin.com/Ed25WeRe

The log file of the standalone is under standalone’s root folder in tomcat/logs

The standalone version I was using was in docker. I can’t have access to tomcat log files.

So to see the logs, I downloaded another standalone version. But when I access “manage modules” to see if the referencedata module is active or not, this is the error I get image

Despite the fact that I can’t access to “manage modules”, I did what you suggested and this is the log: https://pastebin.com/n9AeKiXH

Which version of Java are you running?

@amenikh try to go via >Advanced Administration, >Manage module

I’m running java 8

I used that too. Found that the module is already running. Changed “referencedemodata.createDemoPatientsOnNextStartup” to 50. Restarted the module, but still get the same result, no data.

Can you share your current server log?

This is the tomcat log when I start openmrs standalone https://pastebin.com/Yyvdhp3Y