Could not resolve dependencies for registrationapp

Am working on this https://issues.openmrs.org/browse/RA-1717 ticket. but when I run ‘mvn clean install’ on the branch before making changes, I get this error https://pastebin.com/vETcchC4 I have tried to delete the dependencies in .m2 folder and run afresh but still getting the same error.

cc @cintiadr @dkayiwa , @mozzy

I have been trying to create an openmrs sdk server 2.10 SNAPSHOT for testing purposes using mvn openmrs-sdk:setup command but am running into this error https://pastebin.com/NM5mqcnE. Kindly help me on how to fix it.

@jwnasambu try mvn openmrs-sdk:setup -Ddistro=referenceapplication:2.10.0-SNAPSHOT with mysql running

This is the error log I get https://pastebin.com/wSVY5thx

the errors are due to internet connections

@jwnasambu We really need to get you a reliable internet connection somehow :slightly_smiling_face:

1 Like

I really look forward to it. :slightly_smiling_face:

2 Likes

I kindly need your help. Am setting up a referenceapplication:2.10.0-SNAPSHOT server for testing purposes but am geting this error https://pastebin.com/2LWMPUrk

cc @ssmusoke, @dkayiwa

I am guessing that your MySQL database connection is using root with a blank password

Create a new MySQL user and ensure that they have a password

Thanks for your response. Mysql "root’ has the password which I have conformed from the openmrs - runtime properties.You can confirm from here https://pastebin.com/sPXf6CQm

In that case I would suggest deleting your server and trying to set it up again

Thanks let me do it

@ssmusoke I deleted the server but on try to set up the new server I got the same error log https://pastebin.com/PGjPeYVn

In your error log, i see this The uri is in a wrong format: default -> [Help 1]. Are you the one typing default when asked this? The distribution requires MySQL database. Please specify database uri

If yes, just press ENTER without typing default

1 Like

Thank you so much. Its sorted out on the 5th day after having different errors.

2 Likes

@jwnasambu you can also drop the solution that worked out just to help others