could help me with the necessary modules for to install radiology

Tags: #<Tag:0x00007f0f19c33820> #<Tag:0x00007f0f19c33708>

could somebody help me with the necessary modules for to install radiology

Hopefully @ivange94 and @teleivo are watching this. :slight_smile:

@johnaponte I would say easiest is to use docker. see https://github.com/openmrs/openmrs-module-radiology/blob/master/README.md#install

it will install OpenMRS 2.0 with required modules.

Just to list the modules needed, they are:

dont use the rad module it in production, since its not officially released!

Please answer me one question, so I can improve on that.

Why did you post the question? Readme on github not clear? Or how did you get to the radiology module at first?

If its the wiki, I know I have to update and will so today.

1 Like

Hello, thanks for the answer ,I am a beginner ,I installed OpenMRS /releases/OpenMRS_Platform_1.9.10/openmrs.war , I try to install the module radiology

Why did you post the question?

I work for a hospital that wants to implement “RIS-PACS” I installed “dcm4che” successfully and have done tests with different medical equipment, I wish to supplement with “RIS” with the RAD module for “OpenMRS” I read many documents about that. Could you tell me how successful is this?

Readme on github not clear? I have followed strictly without success, the information is clear, but can not find information compatibility of modules with different versions of OpenMRS

how did you get to the radiology module at first? as you comment I look for a solution to implement “RIS-PACS”

Hello, thanks for the answer ,I am a beginner ,I installed OpenMRS /releases/OpenMRS_Platform_1.9.10/openmrs.war , I try to install the module radiology attached image about modules

When starting the module coreapps I present the following problem and return the service has apparently begun the same problem for the radiology module

you need to install OpenMRS Platform 2.0 which hasnt been released yet, soon it will be :slight_smile: says on the readme under limitations. I will add another sentence maybe under installation :slight_smile:

Are talking about this module:

? Just need to make sure, since this is what I am working on and it is based on OpenMRS Platform 2.0 as I just wrote in the other post. It currently only has a UI using the so called legacy UI.

It seems you are installing the Reference Application with the Radiology App Module @mogoodrich might be more adequate to answer questions regarding it.

I can only say for the https://github.com/openmrs/openmrs-module-radiology it is currently not talking to any PACS, just providing basic radiology workflow to OpenMRS without communication to external systems. we are still under development, so its not officially released.

I found the information here what I want to accomplish https://wiki.openmrs.org/pages/viewpage.action?pageId=60066031 and an additional document

openmrs-radiology-module-installation(1).pdf (599.4 KB)

it is possible to do this ?

this is the old wiki page of the radiologydcm4chee module which hasnt as far as I know been used in production. I picked up development of the radiologydcm4chee module which you can now find at is for https://github.com/openmrs/openmrs-module-radiology this is its current wiki page https://wiki.openmrs.org/display/docs/Radiology+Module

which is also the wiki where you got the installation pdf which unfortunately is outdated, havent had time to update it, am covered in too much work.

but as I said the https://github.com/openmrs/openmrs-module-radiology is not connected to any PACS at the moment. so you can install it using docker as described in the github readme but you dont need any PACS since it doesnt talk to any.

other options are: