Core-apps module.omod failing to build locally

Hello friends am trying to build openmrs-coreapp module, i have build it a couple of times but still omod if failing to build need your help thanks here is the log cc @mozzy ,@gcliff @reagan

try running “mvn clean install” without that update flag ( -U)

1 Like

still its insisting to fail to check ‘npm install --no-optional’ failed

share the entire stacktrace

1 Like

here are the log @reagan without -U flag as in mvn clean install

@sharif npm-install failed to run, checkout the internet connection

Try to re-start your machine and build again

Thanks @gcliff let me try that

Hey @reagan how did you run the core app module, am trying to run a fresh cloned repo from the github of appointmentschedulingui module but am getting the error that the system did not recognise the bower.json file. i tried to delete the file, and do a fresh clean install update but still the same error exist. here is the log error screen shot

cc. @dkayiwa

Is this of help? Eclipse error while compiling AppointmentSchedulingUI

1 Like

Let me see through it thanks

i have used newer version of exec-maven-plugin 1.6.0 but this time get this error -uicommons#master ENOTFOUND Request to failed: getaddrinfo ENOTFOUND

Are you able to access that link from your browser?

1 Like

Sure here is the link after being accessed from the browser {“name”:“openmrs-uicommons”,“url”:“”} the second link directs me to the registration and i don’t think registering will get a direction of being unblocked.

Finally since morning ,after adding a version in one of maven plugin it has run all successfull. but this happened after adding some dependencies , thanks @ for the link you shared

1 Like

Which dependencies did you add?

Added org.codehaus.mojo exec-maven-plugin 1.6.0

and this org.apache.maven.plugins maven-dependency-plugin 2.4