First reaction: I don't like this. Many of these categories (module, distro, maven, owa, book) imply pretty strongly what technology is being used there. (Contrib is the outlier.) "lib" is just too broad. I'd rather have "js" because that seems like more valuable information to be communicating via the name.
I vote to keep the
-js- that Rafal proposes, because it also gives us a place to put "plain JS" libraries that could exist someday. (But I'm fine if we instead go with the convention of openmrs-angularjs-, openmrs-react-, openmrs-js, etc.)
@raff I don't love calling these things just "api" and "ui" because of the strong implication that these are the primary API and UI forever. (Maybe that's fine and we won't have more than one, but I'm just thinking back to the gsp days where we did uilibrary first, and then eventually replaced it with uicommons.)