conflicts when submitting to github

Hello… I have struggled with a certain error ; I finished working on my ticket , now trying to push to my branch but fails with this err ;

procedure :
git branch - O3-1296,
git add,
git commit,
git push origin O3-1296. :face_with_raised_eyebrow: now fails
git push -f origin O3-1296. :sob: again fails

some help ;
what did I miss, in addition which tests do I have to run ?
cc: @jwnasambu , @herbert24 , @samuel34 ,

@josephkagimu1 oh sorry! 6

Most of the time when you get an error like this (speaking in general and meaningful terms) it is either because of :-

1). A syntax error in the yaml file. To solve this, just make sure that your syntax is correct.

2). Or like the error says “mapping values are not allowed in this context”. It means that the keys/values you have used in the yaml, may be syntactically right but not semantically e.g using double quotes (") instead of a single quotes. Just right click on the error and yaml linter will provide you with some option on how to fix the issue.

Besides, why are you using git push -f origin command to push your changes?

thanks @jwnasambu for the direction you provided to me am trying to put it in action to see what am to gain . I used git push -f , just to test and see whether it could help but wasn’t my intention .

I then installed yaml extension in vscode to try solving the issue but haven’t yet solved . @jwnasambu , I have eslint also installed, is it enough to test for code before contribution ?

Oh sorry! Are you available? we can meet on this link https://meet.google.com/hnm-zwdw-yqd

yes that could be better

Kindly join Immediately i only have 10mins.

when I ran yarn run:shell why do I get this => error @jwnasambu thanks for everything

Oh sorry! kindly it has been a while interacting with the esm-core kindly help @vasharma05 please!

@josephkagimu1 was the issue sorted out? I have got some insight and I desire we try out just incase you are still blocked.

thanks @jwnasambu for taking care , I made all the steps but when I ran yarn run:shell , I got this in the browser :point_down:

what could have brought this please ? am still fixed at this point .

I have tried now but still the same error , could there be an error in the building process ? I split the terminal in 2 parts :

  • first terminal : yarn run:shell
  • second terminal : cd packages/apps/esm-login-app . then yarn serve here process successful .

result :
in 1st terminal the process is incomplete see here
in 2nd terminal the process is successful :

at http://localhost:8080/openmrs/spa/login displays the error above still .

@josephkagimu1 kindly is 4pm okay for you for a sync?

(post deleted by author)

@jwnasambu I did every step again from start but finally got simillar errors I got before . Am kindly requesting for some assistance .