Configuring Bahmni to allow for spaces in patient names

When I create a new patient (Registration Module) I cannot enter a lastname with blank spaces. This is very common in latin american cultures. For example: Name: Michael Lastname: Arrollo Hernández

How do I validate it?

Thanks !


This is configurable. The default configuration (which I personally think is too strict) limits names to only letters without accents.

You would need to change this section if you’re starting from the default config. I don’t know if you can just remove those three lines completely, or if you need to replace [a-zA-Z]{0,} with .* (to allow any character).

Darius, Thank you so much, it worked!

Can you share what specific change you made, for the next person who asks this question?

Hi Darius, Sure! Please find below the screenshots of bahmni_config/openmrs/apps/registration/app.json and OpenMRS Advanced Settings respectively:


1 Like