Concept issue in Platform 1.11.5

Tags: #<Tag:0x00007fddeb72b520>

AMPATH is testing platform 1.11.5 and notice there are a couple issues in Concepts.

We would like to know if other implementations have experienced similar issues as those above. If so, how to resolve them?

1 Like

We are just upgrading from 1.6.x to 1.11.x here in Rwanda and so we had not yet done thorough testing of the 1.11 platform, i think identifying these and more issues would be great @ayeung, We can work with the community to resolve all such inconsistencies in near a future 1.11 maintenance releases.

I can’t tell from the Problem #2 screen captures (Adding a mapping). Did you already “Create new term” 555 for ICD10 and save the term? Or did you just enter “555” on this page and “save concept”.

I tried it here and it worked: http://demo.openmrs.org/openmrs/dictionary/concept.htm?conceptId=116128

Ellen Ball

PS to @ayeung - Hey, sister!

Thanks, @k_joseph and @ball.

@ball, it’s not throwing any error after clicking the Save button. However, it’s not displaying the newly added mapping. I think the issue is after adding a new reference term (http://demo.openmrs.org/openmrs/admin/concepts/conceptSource.form?conceptSourceId=30) and then use it for the new mapping, it won’t save. I just tried on the demo site and I am not able to save it.

I just saved a few mappings (ie “icd-0: ADA”). It seems to work. Meet me on skype or let’s screen share.

http://demo.openmrs.org/openmrs/dictionary/concept.htm?conceptId=116128

Thank you so much for @ball’s help on concept mapping issue! The individual concept UI page is actually confusing (at least to me). :slight_smile: So, it requires to use the “Create New Term” if that doesn’t already exist and it will have a pop-up box to allow user to input the information for the new term. After saving the new term, it will then go to search the new term on the code search box and then it will auto-fill the source. What I did was 1) search sauce, enter code, and save. Even though it doesn’t prompt error message as if it’s saved successfully but it actually did not save. I think we can create a ticket for prompting users when such scenario happens to avoid confusion.

Hi @ayeung. On the demo site, I was able to reproduce your first issue of concept displaying in the list twice when searched by number. It’s happening because it’s finding the same concept two different ways; once with the internal ID, and once with its mapping code. Delete the “local” 123 mapping and then search again. Notice now, it only shows the concept name once. If I were you, I would create a ticket for this.

2 Likes

Thank you so much, @arbaughj! I wil create ticket for first issue as well.

You all are more than awesome! :kissing_heart:

1 Like

@arbaughj are you able to reproduce this at? http://uat01.openmrs.org:8080/openmrs

Yes, I can reproduce this at http://uat01.openmrs.org:8080/openmrs, running Last Build: 2016-03-23 11:52 Version: 2.0.0 SNAPSHOT Build 2ba3b4.

Search for concept “116128”. It has the internal ID of that number, and a CIEL mapping of that same number. You see “MALARIA” appear twice in the search results.

Agree with @arbaughj, I can reproduce the same on http://uat01.openmrs.org:8080/openmrs as well.

A ticket for the concept search by ID issue is filed. Please see: