Concept answers wouldn't load after Concept Translation to French


I created a utility that would load the french translations of concepts into the database. It would load the concept , associate a new name entry for locale fr and then make a new name entry in concept_name table.

I can see the entries in the database. The problem is that now when I access my forms which have concept dropdowns, i wouldn’t see any answers. The dropdown is just blank.

As soon as I restart the server, everything works normal as expected. I tried updating the search index, but that didn’t work as well. Can you guys suggest anything that could help me solve this problem?

Best, Sameer

@wyclif can you help?

Did you reindex the table? You can force OMRS to do this by setting the global property “search.indexVersion” to null. I would also like to know what French translations you added. Were these for the Bahmni concepts or some other concepts? Would you be willing to share these with the CIEL dictionary where there are overlaps (we have a lot of French already).

I think you need to give more details, what concepts are you adding to the french names? Is it only answers? only questions? Or both?


I tried doing it from the system administration to see if it does anything, but it din’t help either :frowning: Any other suggestions? I could see this in the logs

INFO - LoggingAdvice.invoke(115) |2018-09-27 15:58:44,781| In method AdministrationService.saveGlobalProperty. Arguments: GlobalProperty=property: search.indexVersion value: null,

We have our local dictionary and once we complete our developement in october, we will be sharing our dictionary.


Hi Wyclif,

These are both questions as well as answers.

May be there is some form of caching going on in html form entry, @mogoodrich are you aware of any caching that happens in html form entry module?

This happens when i create a new server so, I am not sure if caching can be a reason.

Seems like you need to give more details of what exactly you are doing e.g. how, where and when are you adding these french names


I am adding them from a utility class that i created which i run from an activator class.

csv file has fields : uuid, locale, conceptname

Here is the logic :

we try to find a concept using uuid.

if concept found

we create a new name for the concept and save the concept.

Which activator method?

started method

Not sure what could be the issue, I think you might want to share your code that loads the names.


I wanted to know, what would be the ideal way of translating concepts into any language? As mentioned above, we have our own dictionary.

There is 2 sides to the question i.e. programmatically vs not? Programmatically, what you are doing would be fine, why you see the odd behavior I think could be because of where you are doing it. Otherwise going forward you should be using a tool like OCL.