Compilation failure when building LegacyUI module

Question: I’m trying to build and install the legacy ui module so that I can try and help work on issues for the module but I’m getting this error when I do mvn clean install

Update your copy of the core platform with the latest changes from upstream. Compile it. Then try compile the module again.

Everything compiled and I got the .omod for the legacy ui module but now I get this error when I actually try and run core:

Can you paste the full stack trace from the logs at and share with us the link?

Where would I find these? I’m guessing this is some sort of mysql error? I’m using the vagrant setup for development so I’m not really sure I would find mysql logs

Hi Daniel,

So I got the core running but now it doesn’t direct me to the login page anymore like it did before, it just says that the platform is running. Is there a different url that I should point to to actually login to the platform?

You can compile the legacyui module: and drop it in your modules folder. After restarting tomcat or jetty, you should see the login page. We have a ticket to make that text clearer. :slight_smile:

Could you direct me to the ticket so that I can update the wiki install pages for vagrant and any other wiki install pages?

I don’t have a modules directory so should I create one in the webapp directory or in the openmrs-core directory? When I put just the .omod in the modules folder I get this internal server 500 error but when I full the whole legacyui modules project in the modules folder it says “unable to connect”?

Go to where your runtime properties file is ( and create there a folder named “modules”. It is in this folder where you need to paste the modules that you want to run.

@dkayiwa is it possible to run openmrs without the legacyui and just have whatever default ui there is? Because even when I compile and run it normally it still doesn’t give me the login page. I also can’t seem to find where my runtime properties file is to put the modules folder there?

1 Like

I recently pulled and compiled and this is what shows up

In which folder are you putting the compiled module?

Well, you may have to directly visit /openmrs/admin/index.htm or /openmrs/login.htm

I tried both of those but I get this

I’m putting it in the webapp directory of openmrs-core because that is where maven is looking for the runtime-properties. Also should I be putting the whole legacy-ui directory into the modules directory? just the stuff from the legacy-ui target directory? or just the legacy-ui omod file?

It is slightly different depending on whether using jetty or tomcat. First the database has to be setup which includes installing MySQL. After that once openmrs is started it will go into initial setup in which it creates the database and the runtime-properties file. On the last screen of initial setup it will indicate where it is placing the runtime-properties file. That is where you have to create the modules folder and place legacyui omod file. Once you restart openmrs you can go to the admin page to access legacyui.

So I’m using jetty and I have MySQL installed. After the initial setup when I go to the webapp directory to run “mvn jetty:run” it says that it tries to find the runtime-properties in the webapp directory but can’t find it. I think even when I’m not trying to run it with the legacyui-module the admin pages and login page still show HTTP error 404.

I don’t think the message you’re seeing is a real error or the real problem. I recall seeing similar messages on startup of the application all the time.

So I put the “legacyui-1.0-SNAPSHOT.omod” file in my ~/.OpenMRS/modules directory but it still is saying that /admin/index.html and /login.htm isn’t found?