Clinical Visit(Clinical Visit Management): Error communicating with the remote browser. It may have died.(..) [resolved]

Hey @devs! i have had a blocker for a while now. Tests are not running to finish up the scenarios like the way they are supposed to do (for example, the clinical visit tests only end at the first scenario which is adding a visit note, filling in the details and then add the visit note to the table).

All am saying is , only the first scenario is completed so after this error ,the remaining tests (scenarios) are skipped

This is what I tried in that regard but failed:

I installed the standalone-refapp so that i can spin from it thinking it is a network connection issue but it didnt work

i then created a server using the openMRS SDK so that I can spin from it(Just incase it was a network issue) but it didnt yield any fruits yet.

cc: @sharif @kdaud @jwnasambu

@mherman22 Sorry about this, Are you referring to clinical visit Test for RefApp 2.x or RefApp 3.x

we can also look at your code for this via a pr cc @mherman22

1 Like

ooh its RefApp 2.x

i didn’t get you,come again please!!

have you written any code that you are trying to test and its breaking with the above logs?

ooh yeah, lemi get that PR ready cc: @herbert24

take a look → RATEST-164 : Prepare a file in the uitestframework to be deployed within the test instance by mherman22 · Pull Request #47 · openmrs/openmrs-contrib-uitestframework · GitHub

This is usually caused by online servers especially when your connection is not stable. Your are probably using an online server which may not give you a better report on the test especially when your connection is not stable.

Spinning from a local instance will solve the issue.

If the test run can not connect to standalone server, then its something to look into, it sometimes happen when running Ubuntu os though not sure why?. @sharif has an experience on this and can guide !

@mherman22 were you able to set up the server using sdk and running well ?

1 Like

Yeah I did and its running properly

What happens when you use chrome driver and set headless property value to true ?


in case it persists @mherman22 you can also set the headless to false so that you can see the test running and see exactly where it’s failing from. as @kdaud has advised , you can also run on chrome and see if it will pass

1 Like

Thanks, I’ll get back with the experience after doing that .

Thanks , I’ll get back after these changes

1 Like

@kdaud @sharif @insookwa after taking into account the advice given in this talk thread. i did the following:-

  • i installed chrome and then downloaded the version of chromedriver compatitble with my chrome version (which is v93)

  • i then changed my to use the chromedriver.

However i get chrome - which is quite similar to what i got in firefox.

My eyes are drawn to at ✽.a user clicks on Allergies link from Patient dashboard page(file:///home/mherman22/forks/openmrs-contrib-qaframework/src/test/resources/features/refapp-2.x/14-clinicalVisit/clinicalVisit.feature:19) because actually the workflow doesnt exceed this step in the UI

FYI: I have tested this accross all the instances available i.e ref standalone, server created using openmrs-sdk and the online qaserver.

Usually the server can fail the build plan when your PC memory is not well managed. By managing the memory well gives a better result for local build plans. I find this documentation at Troubleshooting Memory Errors - Documentation - OpenMRS Wiki good enough to guide accordingly.

@mherman22 any progress ?

For some reason I have not progressed yet…

@mherman22 do you have some time and we sync to have the issue sorted ?

Yeah , 10:30am okay by you?!

1 Like

just a reminder @kdaud im waiting here →

1 Like

This blocker was solved after a call with @kdaud where we pulled changes from master since my fork was not up-to-date with master. The tests are now passing :airplane: