CI build failure for


i am working on ticket but i keep getting a travis CI failure each time i make PR

@dkayiwa @ruhanga @samuel34

That is a huge upgrade that will not just work out of the box. Can you try go down version by version until when you get to the highest version that compiles without errors?


let me try that

1 Like

@dkayiwa i have tried doing that but it is still failing.

Can you list the versions you tried but failed?

I have tried all those in the category of 3.0.x, 3.1.x, 3.2.x, 3.3.x, and 3.4.x

What errors did you get when you tried the lowest of those versions?

For example 3.1.0, i got this abd after trying 3.0.0, i got

Do you think you can try to get replacements for those failing methods that are needed in the newer versions like 3.0.0?

How do I do that?

For instance replace Database.getTypeName() with Database.getShortName()

1 Like

I have tried this but i am still getting the same error

Can you share a pull request of your changes?

I have done that

Can you also replace LockService.getInstance with LockServiceFactory.getInstance().getLockService

i have done that

Does it reduce the number of compiler errors?

No it doesn’t

Do they increase?

The number still remains the same